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Chapter 1st – Introduction to 
computer 

Q. What is computer? Define the types of computer? 
• A computer is an electronic device. It is versatile machine. A computer can not only store and process 

data but also it retrieve data as and when desire. A computer word comes from compute which means 

calculation. A Computer is a general purpose machine that manipulates of raw facts according to set of 

instruction that are fed into it. 

Types of compute 

Mostly there are two types of computer:-  

1. Analog computer: - are use handle or process information which is of a physical nature, as for example 

Temperature, pressure etc.   

 

2. Digital computer: -are used to process information which is essentially in a binary or two – state form, 

namely Zero and One. When talking about computer, we mostly refer to the digital type of electronic 

machine 

On the basis size, Digital computers are categorized at four categories: 

1. Micro Computer: - the processor is very small so that called micro processor and device is called 

microcomputer. Microcomputer is single user device . Example desktop, laptop, palmtop, 

notebook, PDA etc. 

2. Mini Computer: - the processor of minicomputer is small but larger than micro processor. 

Minicomputer is multiuser device generally used in designing company for commercial use. 

3. Mainframe Computer: - it has larger processor and multiuser device. Number of users is more 

than minicomputer. this is multiuser and multitasking device mostly used in metrology 

4. Super computer: - the processor is biggest than other computer and processing capacity is 

highest than other devices. It is multi user fastest calculating device, generally used in nuclear 

science for calculation purpose. Cray – 1 is the first super computer.  India’s first super computer 

is PARAM -10000. 

 

3. Hybrid Computer :-  it is the combination (mixed) of digital and analog computer 

4. Handheld computer: - Handheld or mobile computing devices are small, compact and portable device 

used typically by those people who work in a mobile environment. Such as delivery services, utility 

company, salesmen and travelling businessman. laptop, palmtop, notebook, PDA etc 

Generation of computer: 

1. First Generation Computer (1946-1958):   

in this generation computer size was very large and use technology of vacuum tube electrical balv , 

hence It had become hot very shortly.  
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2. Second Generation computer (1958-1964) : in this generation use of small transistors . in this 

generation used  of tape and Mash Disk instead of punch card . so the speed of computer had become 

very fast . 

3. Third Generation Computer(1964-1970):  in the third generation computer size has become small  and 

speed fast due to develop  electronics. IBM has introduced IC (integrated Circuit) and use of this in 

Office. Magnetic type and Disk storage has growth by using RAM.  in third generation we found the 

software and hardware separately.    

4. Fourth Generation computer(1970-1985) : in this generation used of MICRO processor and size has 

become very small and speed very fast. Introduced use of graphical user interface so computer use has 

become very easy. 

5. Fifth Generation computer (1985- till date) in this generation found technology of artificial intelligence . 

so we can take decision on computer .  

Characteristic of Computer 

1. Never Tired & Board 

2. High Speed 

3. Accuracy 

4. Storage Capacity 

5. Diversity 

6. Reliable (trust worthy) 

7. All in all 

The Main Components Of A Digital Computer Are: 

 Central processing unit(CPU) 
 Input and output devices 
 Computer memory 
 Concepts of hardware and software       

         
Central processing unit (CPU):   
CPU is the brain of computer. Its primary job is to run program and control the operation of all other 
components such as memory, keyboard and printer. Under the CPU’s control, programs and data 
stored in the memory and results are displayed on the monitor or printed on paper. 
Central processing unit (CPU) also called microprocessor. it is a small chip in computers which receive 
input and provide output. It is composed of silicon and contains millions of transistors for e.g Pentium, 
Dual core, Core 2 Duo, core I3, i5, and i7etc. It consist ALU, Cu and memory Unit.  

Q. Draw an internal diagram of computer system and explain in brief the 

application of various components 
The Major Part Of A Central Processing Unit (CPU) 

a. Arithmetic logic unit (ALU) 
b. Control Unit 
c. Primary or main memory 

 
Arithmetic Logic Unit (ALU): - which performs arithmetic (addition, subtraction, etc) and logical 
operations (Exclusive Or, And) between two numbers. The ALU is a fundamental building block of the 
central processing unit of computer. 
 



DEVELOPMENT TECHNICAL INSTITUTE – 
 

THIS FILE IS CREATED BY MR KAPIL KHANDELWAL DIR (DTI) Page 4 
 

Control Unit (CU):- which extract instruction from memory and decodes and execute them , 
calling on the ALU when necessary. control unit  acts as the central “nervous system” for all other 
components of the computer. 
 
Memory 
The memory is an essential component of a computer system. It is required by the computer system to 
store instructions and data. Memory can be divided into the following two parts.  

a. Primary or main memory  
b. Secondary memory 

Primary or Main Memory 
 Primary memory is a small and relatively fast storage unit that store data and instructions which are 
being currently used by the CPU. This type of memory is also known as main memory. Memory which 
is directly connects to CPU or part of CPU so it is called internal memory of CPU. It retains contents 
only for the time the computer system is on as soon as system it turn off or trip , the main memory loss 
its data hence it is called temporary memory. 
There are two type of primary memory 

1. RAM :  
RAM stands for Random Access Memory. It is read / writes memory. Information can be written 
into and read from a RAM. It is volatile memory; it retains the stored information as long as it is 
supplied with power supply. When the power supply is switched off or interrupted, the stored 
information in the RAM is lost. RAMs of various capacities are available in market for example- 
256Mb RAM, 512 Mb, 1GB and 2GB etc. 
There are two types of RAM 

a. SRAM: abbreviation is static Random Access Memory that is faster and more reliable 
than DRAM. It does not need to be refreshed like Dynamic RAM.  

b. DRAM:  stands for Dynamic Random Access Memory, a type of memory used in most 
personal computers. It refreshed or lost data within few mile second. 

i. SDRAM – stands for Synchronous DRAM, a new type of DRAM, that can run at 
much higher clock speed than conventional memory 

ii. DDR2-SDRAM: stands for Double Data Rate Synchronous DRAM2. 
iii. DDR3-SDRAM: stands for Double Data Rate Synchronous DRAM3 

2. ROM:  ROM stands for Read Only Memory . Computer always contain small amount of Read 
only Memory that holds instructions for starting up the computer. Unlike RAM, ROM cannot be 
written, it is non volatile which means once you turn off the computer the information is still 
there. Rom is permanent type memory. Its content is written into at manufacturing time.  
 There are three types of ROM 

a. PROM (Programmable Read – Only Memory)- A PROM is a memory chip on which data 
can be written only once. The difference between a PROM and ROM (Read Only 
Memory) is that a PROM is manufactured as blank memory, whereas a ROM is 
programmed during the manufacturing  

b. EPROM (Erasable Programmable Read – Only Memory) – is a special type of PROM that 
can be Erased. It can be reprogrammed. 

c. EEPROM (Electrically Erasable Programmable Read – Only Memory) – is a special type 
of PROM that can be Erased by electronically. it can be reprogrammed. 

 
Q. What is Different Between RAM And ROM? 

 

Difference Between RAM and ROM 
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Sr No. RAM ROM 

       1. RAM stands for Random Access 
Memory 

ROM stands for Read Only Memory 

      2.  Ram is Volatile in Nature ROM is Non Volatile in Nature 

3.  Data stored in RAM is erased as soon 
as power supply is switched off 

Data Stored in ROM is permanent in nature  

4.  It is Read/ Write memory It is Read Only Memory 

5.  There are two types of RAM- DRAM & 
SRAM 

There are three types of ROM- PROM, 
EPROM & EEPROM 

 Secondary Memory or Storage Device:   These types of memory are internal or external device 

either inside or outside the computer. It store program and data permanently. It is slower than primary 
storage but has more capacity storage, it is non volatile memory. Secondary memory is not directly 
accessible to the central processing unit of computer.  Some of the common examples of secondary 
storage device are: 

1. Hard Disks:   a Hard disk is a magnetic disk made of metal and covered with a magnetic 

recording surface. Drive is the man action where all data is stored. Most Hard disk drives consist 
of spinning platters of aluminum, glass or ceramic that is coated with a magnetic media. a single 
hard disk usually consists of several platters. The data stored in hard disk can be retrieved at a 
very fast speed. 

2. Floppy Disk:  a floppy disk also called a disk or diskette is a removable storage disk used for 

storing data. It is called floppy disk because the round film inside the disk’s plastic shell is 
flexible (floppy). Floppies are available in 3.5” size with capacity of 1.44 megabytes. 

3. Optical Disks:  optical disks are of two types, namely compact disks(CDs) or CD-
ROMs and WORM (Write once Read Many) disks 

a. CDs or CD-ROM:  CD-ROMs use long spiral Tracks to store data serially. The track is 

divided into blocks of the same size. CD-ROM provide random access data retrieval and 
data indexing , and disk have a shelf life of more than 40 years CD-ROM can store about 
700 MB data. 

b. Worm disks:  WORM stands for write once Read Many.  WORM disk allow user to 

create their own CDs by using a CD-R (CD- recordable) drive. WORM disks are CDs that 
are purchased blank and written onto using CD-R drive. The information recorded on 
WORM disk can be read by any ordinary CD- ROM Drive. But data can be written only 
once. That’s data once written cannot be overwritten 

4. DVD:  DVD stands for DIGITAL VIDEO DISK, or digital versatile disk. DVD disks provide more 

storage capacity than a CD. The disk used with DVD drives is of the same diameter and 
thickness as traditional CDs. DVD cannot be read by CD Drive. DVD disks provide high video 
resolution and high quality of sound.DVD are used for audio and video entertainment such as 
movies, videogames and interactive TV. DVD ROMs capacity 4.7 GB to 50 GB are available.  

5. USB Flesh Drive or Pen Drive:  USB flash drives or pen drives are NAND-type flash memory 

data storage device integrated with a USB (Universal Serial Bus) interface. They are typically 
small, lightweight, removable and rewritable. It is a flash memory card that plugs into the 
computer’s USB port. 

6. Memory Cards: A memory card is a device offering an easy fast and reliable way for storing 

and transferring digital files. A memory card is being non-volatile and solid state.  

7. Magnetic Tap: 
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It is most popular storage medium for large volumes of data that are needed to be serially 
accessed and processed. 

COMPUTER COMPONENTS- INPUT DEVICE 
Data and instructions are entered into a computer through input devices. An input device first 
converts desired input data and instructions into a suitable binary form (0,1)and then feed it 
into the CPU. The  detail discussion of input device below 

1. Keyboard :  
A keyboard is similar to the keyboard of a typewriter. It contains alphabets, digits, special 
characters, functions key and some control key. When a key is pressed, a electronic single is 
produced which is detected by an electronic circuit called keyboard encoder. 

2. Mouse: 
A mouse is a pointing device. It is held in one hand and moved across flat surface. The mouse 
can also be used to draw sketches, diagrams etc, on the monitor screen. As you move the 
mouse , the pointer on the display screen moves in the same direction. It has two button (left 
and right) and one wheel. 

3. Joystick 
A Joystick is also a pointing device. It is used to move the cursor position on a monitor screen. 
Its function is similar to that of a mouse and is used for playing games. A joystick is a stick which 
has a spherical ball at its lower end as well as at its upper end. Joystick can be moved right or 
left , forward or backward. This information is sent to the processor. 

4. SCANNNER: 
Scanners are a kind of input devices. They are capable of entering information directly into the 
computer and scanning document image. The main advantage of direct entry of information is 
that users do not have to type the information.  This provides faster and more accurate data 
entry. 

5. MICR 
MICR stands for Magnetic ink character reader, the MICR device can be considered as a special 
type of scanner. MICR device were developed n the late 1950s, mainly to assist the banking 
industry. MICR detects the special encoded characters on the bank cheques and deposit slip. 
After detecting the encoded character, the MICR converts them into digital data for computer.  

6. OMR (OPTICAL MARK READER) 
Optical Mark Readers are special scanner used for reorganizing a pre-specified type of mark 
made by pencil or pen. For example, in the objective test paper of competitive examinations, 
you mark your answers on a special sheet by darkening a small circle, using a pen or pencil. 
OMR focuses light on the page being examined and the light pattern reflected from the dark 
mark is then detected. 

7. Light Pen: A light pen is a pointing device. It is used to select a displayed menu option on the 
monitor . It is a photosensitive pen like device. It is capable of sensing a position on the monitor 
screen when its tip touches the screen. 

8. BAR-CODE READER : 
Bar-Code Reader is special devices used to read bar coded data. Bar code is a specialized code 

used for fast identification of item. It consists of series of small lines, known as bars.  Actual 

coding of bar is the width of bar, not the height. These are primarily used such as books, postal 

packages, badges.  

9. VIDEO CAMERA:  
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A video camera is a camera that takes continuous pictures and generates a single for display on 
a monitor or for permanent recording. Signals generated by video cameras are traditionally 
analog, but nowadays digital video cameras are available.   

10. WEB CAMERA 
A web camera allows a computer to accept input just by focusing on an object. The camera is 
focused on the input object to take a picture of the object. Picture so taken can be transferred 
over network to a distant place. The image of the object can be seen on the monitor of the 
distant computer connected through a network or through Internet. Voice can also be 
transmitted over the network. Thus, two or more persons can talk and see one another in this 
way. This method is used iv video conferencing. 

11. Optical Character Reader 
It‘s device which detects alphanumeric characters printed or written on a paper. The text which 
is to be scanned is illuminated by a low frequency light source. The light is absorbed by the dark 
areas but reflected from the bright areas. The reflected light is received by the photocells. 
 

12. Track Ball 
Track ball is similar to the upside down design of the mouse. The user moves the ball directly, 
while the device itself remains stationary. The user spins the ball in various directions to effect 
the screen movements. 

 
Computer Component- Output Device 

 
Output devices supplies information or results either in the form of hardcopy (printer) or softcopy 
(Monitor). Some common output devices include. 
Monitor, Printers, Plotter, Multimedia projector, Speech synthesizer 
  

1 Monitor :- Monitors come in two types  
a. CRT (Cathode Ray Tube): - A VDU or CRT monitor is similar to a television and its size 

measured in diagonal length of the screen. it shows text or picture in color or black and 
white, depending on the type color monitors are costlier than black-and white monitors. 
Whatever you type on the keyboard you can see it on the monitor  

b. TFT –LCD (Liquid crystal display) :- LCD monitor is the flat type of monitor found on 
notebook PCs. TFT-LCD (Thin film transistor liquid crystal display) is a variant of liquid crystal 
display(LCD) which uses thin film transistor (TFT) technology to improve image quality. TFT 
LCD is one type of active matrix LCD. It is used in televisions flat panel displays projectors etc. 
 

2 Printer*: - Printers are the most popular output devices. They product printed outputs of 
results programs and data. A character printer prints one their speed ranging from 300-600 
characters per second. Character printers can be classified as: 

a. Impact printers: - Impact printers use an electro mechanical mechanism that causes 
hammers or pins to strike against a ribbon and paper to print the text. Two types of impact 
character printers are available: dot-matrix printers and letter quality printers. 

i. Dot-matrix printers: - dot-matrix printers do not use any electro-mechanical printing 
head to strike against ribbon and paper. They use thermal chemical electrostatic, laser 
bean or inkjet technology for printing the text. Usually a non-impact type printer is faster 
than an impact type. The disadvantage of non-impact type printers is that they can 
produce multiple copies of the text.  
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b. Non-impact character printers Non impact Printer do not use any electro – 
mechanical printing head to strike against ribbon and paper. They use thermal, chemical, 
electrostatic, laser beam or ink jet technology for printing text. Usually a non impact type 
printer is  faster than an impact type. The disadvantage of non impact type printer is that 
they produce only a single copy of the text whereas impact printer can produce multiple 
copies of the text.  

ii. Ink-jet character printers: - It uses the dot-matrix approach to print text and graphics. 
One type of an earlier ink-jet printer model uses one or more nozzles in the print head 
that emit a steady stream of tiny ink drops. Each droplet is charged as it passes through a 
value. Then it passes through horizontal and vertical deflecting plates deflect the ink 
drops to direct them to the desired spots on the paper to form the impression of a 
character. In this type of printer a continuous stream of ink drops is used.  

iii. Laser printers: - Laser printers are non-impact printers. They print one page at a time. 
These printers use laser or other light source to produce an image on a turn it on and off. 
An image is produced following the raster scan principle. The laser exposed areas attract 
the toner. The rafter the drum transfers the toner to the paper. The paper then moves to 
a fusing station where the toner is permanently fused on the paper with heat or pressure. 
Next the drum is discharged and cleaned. Now the drum is ready for processing the next 
page.  
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3. Multimedia projector: - Multimedia projector is an output device connected to PCs and 
used to project information from a computer onto a large screen. It is widely used for making 
presentations. The presenter can directly point to mark or edit the displayed information to 
make it more understandable. Audio video image and animation can be prepared on a PC and 
using a multimedia projector the presentation can be made lively and interesting. 

4. Speech synthesizer: - Speech synthesizer is an output device that converts textual data into 
spoken sentences. To produce the speech basic sound units known as phonemes are combined. 
The sequence of words in a text is combined into phonemes amplified and outputted through a 
speaker attached to a computer. Speech synthesizers find wide application in treating blind or dump 
people. Text information can be read out to the blind people using the speech synthesizer. Also a dumb 
person can type the information he wants to convey and the speech synthesizer converts it into spoken 
words.  

5. Speakers: -Speakers are also kind of output devices which is used to play a sound as output. It is 
used in multimedia applications to play or listen to sound or music. 

6. Projector: -Projector is output device and often used in meetings presentations. It contains a 
lens inside  which is used to flash the film to a object 

CONCEPT OF HARDWARE AND SOFTWARE 
A. Hardware: -The physical components of computer are known as hardware such physical components 

may be electronic magnetic, circuit (ICs) hard disks, floppy disks optical disks color monitor keyboard 
printer and plotter etc.  

B. Software: -It is the set of computer programs, procedures, and associated documentation 

related to the effective operation of a computer system. 
Role of software in Computer: -A set of instructions that perform a particular task is called the 
program, or software program. The instructions in the program direct the computer to perform 
input operations, process the data and output the results. 
Type of software: -The software is classified into following categories: 
 

 

System Software*…… 
System Software: System software is a type of computer program that is designed to run a computer’s 
hardware and application programs. If we think of computer system as a layered model, the system 
software is the interface between the hardware and user applications. 
The operating system (OS) is the best known example of system software. The OS manages all the 
other programs in a computer. In general, system package support the following: 

a) Running of other software 
b) Communicating with peripheral devices such as printers, card readers, and disk and tape 

devices. 
c) Development of other types of software 
d) Monitoring the use of various hardware resources such as memory peripherals, CPU, etc. 

Software

Application 
software

User Written 
Software

ready made 
Software

Utilities
System 

Software

Compilers
Operating 

System

Packages
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System software thus makes the operation of the computer system more effective and 
efficient. 

Application Software* 

An application is a program or group of programs designed for end users. Application software (also 

called end user programs) includes database programs, word processor, and spreadsheets. Figuratively 

speaking, application software sits on top of system software because it is unable to run without the 

operating system and system utilities.  

Application software can be divided into the following categories  

• Word processors e.g.- Ms word, WordStar etc 

• Spread sheet package e.g.- Ms- excel, Lotus-1-2-3 

• Presentation package e.g.- Ms – Power Point, Flash 

• Database Package e.g.-  Ms- Access, SQL server 

• DTP package e.g.-  Adobe Photoshop, page maker, coral draw 

• Utility Software e.g.- Antivirus, Disk Cleanup, Disk Defragmenter 

• Customized Software e.g. Railways reservation system  

Shareware Software 

Shareware is a marketing method for software, whereby a trial version is distributed in advance and 

without payment, as is common for proprietary software. Shareware software is typically obtained free 

of charge, either by downloading from the Internet or on magazine cover-disks. A user tries out the 

program, and thus shareware has also been known as ‘try before you buy’, demo ware, and trialware 

and by many other names. A shareware program is accompanied by a request for payment, and the 

software’s distribution license often requires such a payment. 

Free software: 
“Free software” means software that respects users’ freedom and community roughly, the users have 
the freedom to run, and copy, distribute, study, change and improve the software. With these 
freedoms the users control the program and what it does for them. 
 A program is free software if the program’s users have the four essential freedoms. 

 The freedom to run the program, for any purpose 

 The freedom to study how the program works and change it so it does your computing as you 
wishes. Access to the source code is a precondition for this. 

 The freedom to redistribute copies so you can help your neighbor 

 E.g. CCleaner Avast Anti Virus. 
Proprietary Software 
This means that someone owns the rights to the program, and the owner expects users to buy their own 

copies. Microsoft Office is a typical example. If you want to acquire this software to write letters of 

produce graphics, you must purchase a registered copy in a store, through a mail order house, or over the 

Internet. In buying the software, you pay not own it, but to acquire a license that makes you authorized 

user. Organizations such as businesses and schools, which may need software for use by several people, 

generally acquire site lances that allow access by multiple users. 
Compilers 

Compiler is a translator which convert high level language into machine level language. it execute the 

whole program at once. it is faster than interpreter. compiler shows list of errors along with line number 

at the end of program execution.  

Interpreters* 

interpreter is a also translator which convert high level language into machine level language. it execute 

the program line by line. it is slower than compiler . interpreter shows error line by line. it is smaller 

program as compared to the compiler   
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Difference between System Software & Application Software ? 

System Software   
1.  System software gets installed when the operating system is installed on the computer 
2. System program includes programs such as compilers, debuggers, drivers, assemblers. 
3. Generally, users do not interact with system software as it works in the background 
4. A computer may not require more than one type of system software 
5. System software can run independently of the application software 

Application Software 
1. Application software is installed according to the requirement of the user 
2. Application software includes media players, word processors, and spreadsheet programs 
3. Users interact with application software while doing different activities 
4. There may be a number of application software program  
5. Application software cannot run without system software 

 

Exact Number Of Bytes 

Unit Smallest Unit ----------------- 

Nibble 4 Bits --- 

Byte 8 Bits --- 

Kilobyte (KB) 2010 Bytes 1024 bytes 

Megabyte (MB) 2020 Bytes 1024 KB 

Gigabyte (GB) 2030 Bytes 1024 MB 

Terabyte (TB) 2040 Bytes 1024 GB 

Petabyte (PB) 2050 Bytes 1024 TB 

Exabyte (EB) 2060 Bytes 1024 PB 

Zettabyte (ZB) 2070 Bytes 1024 EB 

Yottabyte (YB) 2080 Bytes 1024 ZB 

 
There are four types number. 

 Binary number (0,1) & base 2   

 Decimal Number (0-9) & base 10  

 Octal Number (0-7) & base 8 

 Hexadecimal Number (0-9,A-F) base16 
 
 

Exercise 
1. Convert (6806)10 to Binary and (7305)8 to Hexadecimal. 

2. convert binary number 100111 into a Decimal number 

3. convert decimal to binary number : 75, -50 

4. convert binary to decimal number : 00010111, 00001111 

5. Convert (A8c4) 16 to octal 

6. Decimal equivalent of the binary number 110111 is- 

7. .......... is the decimal equivalent of 100100 

8. convert D6FA to Decimal 

9. convert (7706)8 to Hexadecimal 

10. Convert (7305)10 to octal 

11. convert (1765)8 to Hexadecimal   

12. convert (11001)2 to decimal Number 
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13. convert binary number 100111 and 101.11 into hexadecimal number 
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Chapter -2 Operating System 

Q1. What is Operating system? Define the various function of OS?  

Operating system (OS) is a software program that control the internal activities of the computer 
hardware and provide user interface. Application programs also need to interact the operating system 
for using hardware resources. OS is the first program loaded (copied ) into the computer’s main 
memory after the computer is switched on. 
One of the primary jobs of the operating system is to provide an interface between the user and the 
hardware. 
Operating system performs the following functions: 

1. Processor management:  
2. Memory management 
3. Input/output management 
4. File Management 
5. Scheduling  
6. Timesharing 
7. Security management 

PROCESSOR MANAGEMENT:  
The operating system assigns processors (if a computer has more than one processor) to the different 
task that must be performed by the computer system. 
MEMORY MANAGEMENT 
It (OS) allocates the main memory and secondary memory to the system programs, user programs and 
data. 
INPUT/ OUTPUT MANAGEMENT 
It carries out the input / output management and coordinates and assign different input and output 
device. 
FILE MANAGEMENT 
It manage file on various storage devices and the transfer to these file from one storage device to 
another. It also allows all files to be easily changed and modified through the use of text editors or 
some other file manipulation software package. 
SCHEDULING 
It establishes and enforces the job priority. That is , it determines and maintains the order in which jobs 
are to be executed in the computer systems. 
TIMESHARING  
It co-ordinates and assign compilers, assemblers, utility programs, and other software package to 
various users working on the computer system. 
SECURITY MANAGEMENT 
It establishes data security and integrity. That is , it keep different programs and data in such a manner 
that they do not interfere with each other. It also protects data from being destroyed by any other user. 

Q2. What are the various types of operating system? 
a) Single User Operating System-: operating system which allow only one user to work on a 

computer at a time is knows as single user operating system. Example including DOS. 
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b) Multiuser Operating System:  operating system which allow number of  user to work 
together on a single computer at a time is knows as Multi user operating system. Example including 
UNIX, LINUX 
 

c) Single Tasking Operating System : operating system which can execute a single job at a time is 
known as single tasking operating system. For example, MS -DOS 
 

d) Multitasking Operating system :  Multitasking operating system allow user to perform more 
than one job at the same time on a computer. Most of today's operating system such as 
windows 9x, Os/2, Unix, LINUx etc. support multitasking . 

e) Real Time Operating System-: Real time operating systems works towards providing immediate 

processing and also responding to user's command in a very short time. Its aim at executing 

real time applications. Success of real time system does not depend only on the correctness of 

the result, but also on the timeline of the result. A correct answer obtained after the expiration 

of time limit is as bad as a wrong answer. Some example of Real time operating system are HP- 

RT and VTWorks. 

f) Network Operating System :- Network operating systems (NOS) is an operating system 

specifically designed to support interconnection of several computers. NOS provide support for 

multiuser operations as well as administrative, security and network management functions. 

Some example of NOS are Novell's Netware 

g) Distributed Operating system: -: an operating system that manages a group of independent 

computers and makes them appear to be a single computer is known as  a distribute operating 

system. 

Q3. What is Linux Operating System? Define the important parts of Linux. what 

are the advantage of LINUX over windows? 
Linux is a multiuser, multitasking & open source  operating system first developed by Linux Benedict 
Torvalds in the year 1991. Linux is a 32 bit operating system. It runs on a wide variety of platform such 
as intel, sparc, Alpha etc.  
it can be considered in every sense as a full –blown implementation of UNIX. But it cannot be called as 
UNIX because UNIX is a registered trademark product owned by AT & T.  
LINUX is a distributed as a free software under a free software license called the GNU general Public 
Licence(GPL). 
THREE IMPORTANT PARTS OF LINUX OPERATING SYSTEM ARE: 

1. Kernel 
2. Shell 
3. File System 

KERNEL 
The kernel is at the core of LINUX system and is loaded into the memory as soon as the system starts 
up. It manage main memory, files and peripheral devices. Maintaining the time and date, launching 
applications, and allocating system resources are also functions of this part of the operating system. 
Shell 
Shell is a program which interprets commands given by user. The command can be either typed in 
through the command line or contained in a file called ‘shell script’. Commands in ‘shell script’ files are 
interpreted by the shell  
File System 
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Linux treats everything as file. Even a directory is treated as a file that contains entries for 
several other files. All the hardware devices, such as I/O devices, storage devices etc. are all treated as 
files. 
The Linux files system is organized in a hierarchy which starts with the root directory . The root is 
represented by a forward slash(/). Under the root directory are several system directories and the 
home directory. 
Advantage Of Linux Over Windows 

1. Easy to install applications . Installing new programs in Linux is easier than in windows 
2. The majority of Linux variants are available for free or at a much lower price than Microsoft 

windows. 
3. It is rarely attacked by viruses 
4. Linux community on the internet is very active and helpful. 
5. It is easy to find solutions to problems 

Q5. What is Role of Disk Defragmenter & Disk Cleanup in Windows? 

Disk Defragmenter-:  Disk Defragmenter consolidates fragmented files and folders on your computer’s 

hard disk, so that each file occupies a single, contiguous space on the volume. As a result, your system 

can gain access to your files and folder and save new ones more efficiently . By consolidating your files 

and folder, Disk Defragmenter also consolidating the volume’s  free space, making it less likely that new 

file will be fragmented. 

Disk Cleanup -: You can use Disk Cleanup to free space on your hard disk by removing temporary 
internet files, installed components and programs that you no longer use, and emptying the recycle bin. 
Computer clean up tools are available in windows.- 
Click on start button  All Program   accessories  System Tools  Disk CleanUp. 

 

Q. What is cache memory ? 
Cache memory (pronounced as the "cash memory") is placed in between the cpu and the main memory. It is 

faster than the main memory. Hence access time is much less than that of the main memory. The access time of 

a cache memory is 15-25 nanoseconds whereas that of the main memory is 80ns. One nanosecond = 10-9 

second. The cache memory stores instructions and data which are to be immediately executed. It is used to 

reduce the average access time for address, instructions or data which are normally stored in the main memory. 

Thus it increase the operating speed of the system. Cache memory is much costlier than the main memory. 

From economical considerations, the size of cache memory is usually smaller than that of the main memory.  

 

Q7. What is Virus ? classified the category of VIRUS ? 
A Virus is a program created by programmers to infect the operation of a computer system. After the virus code 

is written, it is buried within an existing program, and, once that program is loaded into the computer, the virus 

replicates by attaching copies of itself to other programs in the system. Virus are normally found in the network 

environment. 

Viruses are classified in the following types : 

A. Trojan Horse 
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B. Time and Logic Bombs 

C. Melisa and SKA Virus 

D. Malware 

A. Trojan Horse :  a virus is called a Trojan horse that continues to infect programs over and over 

again. It also pretends to do something useful or interesting . But when run, it produces some harmful 

effects like scrambling FAT (File Allocation Table) or formatting the Hard Disk. 

B. Time and Logic Bombs :   A Time and logic bomb is a program that destroys data. For example, 

it may reformat the hard disk or randomly insert garbage into data files. A time bomb as the name 

suggest, is triggered by an event. It can format the hard disk on a given data or slow down computer 

every Friday or make a ball bounce around the screen.  

C. MELISSA AND SKA VIRUS :  Melissa virus attacks MS- Word documents and spreads very fast. This 

virus affects word documents by installing itself to normal.doc and disabling the macro protection 

message and infects all the word files open or created subsequently. The message generated by the 

virus says " Here is a document you asked for .. don't show anyone else." 

D. Malware : it is short of "Malicious software" malware refers to software programs designed to 

damage or do other unwanted actions on a computer system. In Spanish, "mal" is a prefix that means 

"bad" making the term "badware" which is good way to remember it. Common example of malware 

include virus  worms, trojan horses, and spyware. 

Spyware can gather data from a user's system without the user knowing it. This can include anything 

from the a user's system without the user knowing it. This can include anything from the web pages a 

user visits to personal information, such as credit card numbers.  

What is BUG ? 
A software bug is the common term used describe an error, flaw, mistake, failure, or fault in a computer 

program or system that produces an incorrect or unexpected result. It may cause it to behave in unintended 

ways. Most bugs arise from mistake and errors made by people in either a program's source code or its design, 

and a few are caused by compilers producing incorrect code.  

What is Multimedia ? 
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Chapter -5 Basic of Word Processor 

Q. Give Different feature of word processing which makes it useful for 

administrative staff. 

Introduction  

word processing package such as word 2007 helps enter text and manipulate words and phrases. You 

can change typed letter, document and report easily and store them for future use.  You can even print 

these documents created on a word processor can be made accurately , giving better look and printed 

for use . A word processor allows you to function more effectively and efficiently with minimum effort .  

WORD PROCESSING TERMINOLOGIES / Feature 

1.  Word Wrap : A word processor automatically moves the text to the next line when you type 

beyond the right margin. This is known as Word Wrap.  

2. Editing of text : With a word processor, you can insert new words, new sentence or new 

paragraphs anywhere in the text typed earlier. The new text will get adjusted automatically. 

Similarly, you can delete any portion of the text and the remaining part of the matter will get 

adjusted automatically.  

3.  Selection: A selection is a group of words that are put together . A word processor can perform 

various operations on a selection, such as copying, moving or deleting. 

4. Moving / copying selection : You can move a selection to another Location in the same document or 

copy the text at another location with the help of a word processor. This saves the effort of retyping 

the text. 

 

5. Search and Replace : With a word processor you can a search for any specified word or character in 

a document and replace it with another word as desired.  

6.  Dictionary / Grammar Check :If a word in your document does not match with the word in the 

dictionary, it means that either that word is misspelled or that the word is not loaded in the dictionary. 

The dictionary features will make a list of unmatched words for you to take appropriate action. If your 

document is legal or technical one, you can even use a legal/technical dictionary for checking spellings.  

7. Character Styles And Sizes You can change the type and size of characters so that a printed 

document appears more attractive and professional. You can use bigger and bold letters for main 

headings. You can use italic character to emphasize a word.  

8.  Header footer and page numbering: A header is a special text which is printed at the top of each 

page above the normal text. Footer is a special text which is printed at the bottom of each page. Word 
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2007 can generate page numbers automatically in a document and also print headers, footers 

on each page.  

9.  Margins and columns : The left and right margins are the distances between the text and the left 

and right edges of the paper. It is normally one inch but you can adjust it easily.  

10.  Justification Of The Text : Justification is the alignment of the text typed within the given margins. 

The text can be left, right, centre or even justified. 

in the left justification, the text has a straight left edge and an uneven right edge. 

in the right justification, the text has a straight right edge and an uneven left edge. 

in the right justification, the text appears between the right and left edges of the paper. 

In even (full) justification, the text is aligned on both the left and right margins of the page.  

11. Line Spacing :  In a word processor, the spacing between the lines can be adjusted. You can leave 

one or more blank lines between every two typed lines but the default line spacing for a word 

processor is single line spacing. When one line is left blank between two typed lines, it is known as 

double line spacing. This kind of spacing is normally used for draft letters.  

12.  Tab Setting  You can set tabs in a word processor for typing columns in a document as in the case 

of a typewriter. You may want to use the ruler to set manual tab stops at the side, middle and right 

side of your document.  

 13.  Tables : A table is made up of rows and columns of cell that you can fill with text and graphics. 

Tables are  used to organize and present information, but they have a variety of other uses as well. You can 

use them to  align numbers in columns, and then sort and perform calculations.  

14.  Hyphenating Documents: The hyphenation features of a word processor can break or hyphenate 

words so they may fit better on a line. Word 2007 can hyphenate the words in a documents 

automatically as you type or manually when you have finished typing. 
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Chapter -6 Basic concept of word 2007 

6.1 Introduction : in this chapter, you will first familiarize with the working environment in word 

2007. The ribbon is designed to help you find the commands quickly, and then you will add button to 

word 2007 quick access toolbar. Then you will be creating and opening an existing word 2007 

document, saving, printing, moving around in it, and quilting word 2007.  

6.2 Starting Word:  

To start word 2007, do this: 

Click Start button  All Programs  Microsoft Office  Microsoft Word 2007   

6.3 Using word 2007 interface : There is a new look for word 2007 and a new interface that 

replaces menus, toolbars and most of the task panes from previous versions of word with a single 

mechanism that is simple and easy to learn. The new interface is designed to help you to be more 

productive. You can find the right features of various tasks more easily, discover new functionality and 

be more efficient.  

 

6.3.1 Office Button: This button is located in the upper left corner of the word 2007 window. The 

command related to managing word and word documents are gathered together on an office button 

displayed as you click that button.  

 

6.3.2 QUICK ACCESS TOOLBAR : This toolbar is located by default at the top of word 2007. 

window by default this toolbar displays the save, undo and repeat buttons. 

 

6.3.3 Dialog Box Launchers: Dialog box launchers are small icons that appear in some groups. 

clicking a dialog box launcher opens a related dialog box or task pane, providing more options related 

to that group.  

6.3.4 Word 2007 Document Window :  

1. Title Bar:  it is the top of an open window and is called title bar. 

2.  Minimize Button : an underscore(_) at the right of a title bar which stores an application 

programmed at the bottom of the screen. 

3. Maximize Button : a box at the right of a title bar that fill available space with the document or 

application. 

4. Close Button: a box at the right of a title bar marked as (X) that close the window or dialog box , 

when you click it with a mouse pointer. 

5. Restore Button: a double  at  the right of the a title bar that  restores  an application or 

document into a sizable window. 

6. Help Button: It appears at the right end of the ribbon. When the mouse pointer is over any 

button  for a few seconds it display a screen tip with not only  the button ‘s name but also its 

function 
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7. Status Bar: A the button of the window ,the status bar gives you  information about  the  

current  document . You  can turn  off the display of an item of information by the right –click 

the status bar and then clicking that item. 

8. View Toolbar : At the right end of the status bar is the view toolbar. It  provide tools for  

adjusting  the view of  document. 

9. Mouse Pointer: The on screen arrow ,I beam ,or drawing   button indicates the  current location  

affected  by mouse actions. 

10. Select Browse Object :The toolbar that enables you to browse  through  an active document  by 

field , endnote ,comment, section page ,edits ,heading ,graphics, or by table. Go to and find 

functions are also part of this toolbar. 

11. Split Box : Light gray bar at the top of vertical scroll bar that you can drag down to split a 

window into two views of the same document. 

12. Screen Tips: screen tips  show the name of the  command  button shown in ribbon .screen tips 

appear  as soon as you  position the mouse pointer on the selected tabs commend.  

13. Ribbon : Ribbon is displayed just below the title bar. In ribbon, commands are organized in 

logical groups, which are collected together under tabs . You can hide the ribbon by double-

clicking the active tab. Different type of tabs are available in word 2007.  

a. Home Tab:  This button is related to working with document such as clipboard, font, 

paragraph, styles and editing.  

b. Insert Tab: This button is related to items you can insert-tables, header and footer, and 

symbols, picture, clipart,wordArt, Smart Art, Textbox etc. 

c. Page Layout Tab : This button is related to the appearance of the document such as 

page setup, page background, watermark, Paragraph, themes and arrange. 

d. Reference Tab:  This Button is related to item you can add to long documents such as 

table of contents, footnotes, Bibliography, captions, index and table authorities. 

e. Mailing Tab: This Button is related to creating Mass Mailing  

f. Review Tab : This button is related to proofing, commenting and changing document 

such as spelling & grammar, treasures. 

g. View Tab: This button is related to changing the view or the display of documents 

 

14. Scroll Bar : The scroll bar appear at the left for vertical scrolling and at the bottom for 

horizontal scrolling as seen in word 2010,you can work simultaneously with more than one 

document. 

 Customize the Quick Access Toolbar. 

1. At the Right hand Side of the quick Access Toolbar, click the customize quick access Toolbar 

Button 

2. Click any one option you need it (To add Button in quick access toolbar) 

3. Right Click any Option   Click on Remove From Quick Access Toolbar 

 

     15. Ruler : The Ruler Helps you to Control the Margins, the Paragraph indentation and the tab 

settings for a document. 

Displaying or Hiding Rulers :   
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1. Click on View Tab  Select The Ruler Check Box 

2. Click on Ruler Button just above the vertical scroll Bar (Second Method) 

 

6.4 Working With  A Mouse: 

6.4.1 Mouse Terminology with word: 

Action Function 

Point Position the Mouse Pointer on an Item 

Single Click  Move the cursor wherever you click 

Double Click Select a single Word  

Triple Click  Select the Entire Paragraph 

Drag Press And Hold Left Mouse Button as you move 
the mouse to new location, and then Release 
Button. 

 

6.4.2 Shape of the Mouse Pointer:  the Mouse Pointer changes shape, depending on what you are 

pointing to task you are performing. 

Pointer Location Function 

 Text Area  Type, Select text, or Reposition 
the insertion point 

 Command On the Tabs, inactive window, scroll 
bar, toolbar or Ruler 

Choose Commands, click 
buttons or drag 

 Selection Bar, table Selection, style area along the 
window's left edge 
 

 

 Within a selection when you hold down the left 
mouse button 

Drag the Selection to a new 
location where you insert 

 Along  the Slides, top ,bottom or corner of the 
window, frame or embedded object or picture 

Drag to Resize a window, frame, 
graphics, or embedded object or 
picture vertically or horizontally. 

 

6.5 Using Word 2007 

 Creating a Document 

 Typing and Editing a document 

 Opening and saving a document 

 Moving around in a document 

 Printing a document 

 Closing a document and quitting from word processor 

Problem No1. To Create a New Document, do this:   (Ctr+N) 

1. Click on OFFICE BUTTON → Click on New option 

2. Select Installed Template from Left Pane 
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3. Click Oriel Letter template 

4. Editing your document 

Problem No2. Typing and Editing a Document 

Word-wrap: you can start typing in a document without worrying about the end of the right margin. 

Words at the end of the line will automatically wrap text to the next Line. 

You May correct the text by pressing BACKSPACE key 

Saving Document 
The First time you save a file, you need to specify three items: 

1. The Drive and Folder (in which you want to store file) 

2. The Name of File 

3. The Format to save the file 

Problem No3 .  Save a New Document, do this:     ( Ctrl+S) 

1. Click on Office Button 

2. Click on Save Option 

Save AS Dialog Box appear on the screen 

3. Select Drive → Folder → 

4. Type File Name DTI in box 

5. Click on Save Button 

Problem No4. To Opening an Existing Document, do this: (Ctrl+O), (Ctrl+F12) 

6. Click on Office Button 

7. Click on Open Option 

Open Dialog Box appear on the screen 

8. Select Drive → Folder → File 

9. Click on Open Button 

Problem No-5 Print Preview & Print A Document   (Ctrl+F2), (Ctrl+P) 

Before you print a document, it is necessary to preview it to check page breaks and the overall 

appearance of the document. 

1. Click Office Button → Print → Print Preview  

2. Click on Print Option 

3. Select Desire Setting → Click Ok Button 

Problem No- 6 Closing, opening Document and Quitting Word 2007 Ctrl+W 
1. if you want to close the previously opened document choose OFFICE BUTTON →Close 

2. To Quite word 2007 click OFFICE BUTTON → Exit 
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Chapter -7 Editing word 2007 
document 

7.1 Typing Text: 
When you open a new document in word 2007 the insertion point is at the top left corner of the screen. you can 

start typing in this document. you can  make changes at any time by editing the document. 

7.2.1 Typing New text over the Existing text: 
By default, word 2007 moves the existing text to the right as you insert new characters. if you want the new text 

to  replace  the existing text, character by character, switch to overtype mode. 

Problem No7. To  type over the existing text, do this 

Method 1st : 

1 Right Click on status bar → Click Overtype Mode 

Method 2nd : 

1. Click Office Button → Word Option  

2. Click on Advance Button 

3. Select The Insert key to control overtype mode check box 

4. Click on Ok Button 

Problem No8. Starting a New Paragraph   Enter Key 

 A paragraph ends whenever you press the ENTER Key. even if you not typed any text . 

 To start a new paragraph , and press the ENTER Key 

Problem No9 . Starting a New Line    Shift+Enter 

Word automatically wraps text to the next line when the types text reaches the end of the right 

margin.  

to start a new line within same paragraph press →Shift + Enter Key 

7.3  Applying Correction In The Typed Text 

To Delete Key Combination 

Selected Text BackSpace or Del 

Character before the insertion point Backspace  

Character after  the insertion point Del  

A Word before the insertion point Ctrl+ Backspace 

A Word after the insertion point Ctrl+Del 
 

7.4 To Restore or Undoing Mistakes 
If you mistake in word 2007, you can apply "undo" command. There are certain action cannot undo, 

such as saving or printing a document.  



DEVELOPMENT TECHNICAL INSTITUTE – 
 

THIS FILE IS CREATED BY MR KAPIL KHANDELWAL DIR (DTI) Page 24 
 

1. Click the undo (reverse) / Redo (forward) button from quick access toolbar   

or 

2. Press Ctrl+ Z or Ctrl+ Y for (Undo/ Redo) 

7.5 Select the Text with the Pop-up Toolbar 
Word 2007 displays a popup toolbar. For example, select the text you want to apply formatting such as bold , 

font size etc, a pop up toolbar appears to the upper right of the selected text as a faint image. the closer you 

move the mouse towards this pop - up toolbar, the darker and sharper the toolbar appear as seen. 

  Problem No10 .  How to use pop-Up toolbar     
1. Type text or paragraph 

2. Select with mouse using drag option 

3. Move the pointer 

4. A pop-up toolbar appear on the screen 

5. Do action such as - Bold, italic, color, size etc. 

7.6 Moving or Scrolling with a keyboard 
Sr 
No 

To Move Press 

1.  One Character Left  Key 

2.  One Character Right  key 

3.  One line up   Key 

4.  One line down  key 

5.  One word to the left Ctrl+  key 

6. One word to the Right Ctrl+  key 

7. To the end of a line End 

8. To the beginning of a line  Home 

9. One Paragraph Up Ctrl+  

10. One Paragraph Down Ctrl+  

11. Up one Window PgUp key 

12. Down one Window PgDn Key 

13. To the top of the next page Ctrl+PgDn 

14. To the top of previous page Ctrl+PgUp 

15. To end of document Ctrl+Home 

7.7 Using Go To Command: 
You can move quickly to a location in a document using the Go To Command. For  this command, you specify, a 

page, section, line, footnote, table headings, etc. For example, you can use the Go to command with page 

numbers to move back forth between page in a document.  

  Problem No11 .  How to use Go To Command   Ctrl + G   
1. Click on Home Tab 

2. Click on Find Next Arrow  Go to Button 

3.  Find and Replace Dialog Box is displayed on the screen 

4. In the Go to What: list box  Select Page 

5.  in the Enter page number: +5 

6. Click on Go To button 
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7.8 Moving to a Previous Location: 
Word 2007 remembers the last three locations where you typed or edited text. Pressing Shift+F5 (Go Back Key 

combination) returns the insertion point each of the previous location in turn, then return the insertion point to 

its original position. 

To Return to a previous editing Location, do this: 

 Press Shift+F5 key together until you reach the location you want. 

7.9 Selecting Text for Editing: 
A. Selecting Text with a Mouse: 

Text To Select Mouse Action 

A Word Double - click the word 

A sentence Ctrl+ mouse left click 

A lines Click selection bar 

Multiple Line Click selection bar and drag up or down tile the end of lines 

A Paragraph Double- click selection bar 

Document Ctrl key and click in selection bar 

 

B. Selecting Text with a Keyboard 

 

C. To select from the insertion point to a distant location, do this: 

 Move insertion point to the beginning of the text you want to select 

 Press F8 key (Extend Selection) 

 Press one of the key listed in the table. 

To select  Press 

Next or Previous Character  Or  arrow key 

The End of line End Key 

The Beginning of a line Home key 

The top of the previous screen PgUp key 

The bottom of the next screen PgDn Key 

The begining of a document Ctrl+Home Key 

The End of a document Ctrl+End Key 

Text To Select Mouse Action 

A Word Shift+Ctrl+  or  

Paragraph Shift+Ctrl+ Or  

To the beginning of a line  Shift + Home 

To the end of a line Shift+ End 

One line at a time Shift + or Shift +  

To the beginning of Document Shift+Ctrl+Home 

To the End of a document Shift+Ctrl+End 
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7.9.1  Using Find And Replace:: 
Word  2007  has a very powerful, find and replace feature which greatly simplifies editing of text. The 

Editing command is in the home tab for finding and replacing text. 

Finding Text:  

With the find feature in word 2007, you can locate a specific text. You can also search for special 

characters, such as tabs, page break, extra space, line numbers, footnotes etc within a document. 

Problem No.12  How to find specific Text  in document:   Ctrl+F 

 

 Click on Home Tab 

 Click on Find Button 

Find And Replace Dialog Box is displayed on the screen 

 Type text in Find what Text Box 

 Click on Find Next Button 

Replacing Text: 

You can replace searched text automatically using replacing text  faciltiy in word 2007. You can use the 

replace command to search for every occurrence of the incorrect spelling and replace it with correct 

version. For Example replacing incorrect word dcument with document 

Problem No.12  How to Replace specific Text  in document:   Ctrl+H 

 

 Click on Home tab 

 Click on Replace Button from Editing Group 

Find And Replace Dialog Box is displayed on the screen 

 Type text in Find what Text Box 

 Type text in Replace with Text box 

 Click on Replace  Button (to replace only one) 

 Click on Replace All ( to Replace all word in document) 

 Click Cancel or press Esc Key to Return to the document 

Problem No.13  Moving Text and Graphics using Drag and Drop Technique    

1 Select Text or Graphics you want to move 

2 Point to the selected Text or Graphics 

3 Press hold down the left mouse button 

4 Release the mouse button to drop text at desired place 

Problem No.14  Copying Text and Graphics using Drag and Drop Technique    

1 Select Text or Graphics you want to move 

2 Point to the selected Text or Graphics 

3 Press hold down Ctrl key with  left mouse button 

4 Release the mouse button to drop text at desired place 
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7.9.2 Using Keyboard shortcuts for moving and copying 
Action Key Combition 

To copy text Ctrl+C 

To Move Text  Ctrl+X or Shift +Del 

To clipboard  Ctrl+V or Shift + Ins 

Move a paragraph up Alt+Shift+ 

Move a paragraph Down Alt + Shift +  

 

Pasting the same text or Graphics in several locations: 
The clipboard is a temporary memory area for holding text and graphics. Each time you use the cut or copy 

command, the selected text or graphics copies the contents to the clipboard . after you paste that into a 

document, a copy of it still remains on the clipboard. Therefore you can paste the selected text again whenever 

you want to in the document. 

Student Assignment: 
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Chapter – 8 word 2007 Editing Tools 

8.1 USING SPELLING CHECKER:  

The Spelling checker is a flexible and powerful tool will automatically check spelling in a paragraph 

or the entire document. It finds and corrects the spelling errors but does not consider the context 

of words. For example, it cannot check the improper usage of various words, namely farm in place 

of form or no in place of know.  

Checking a document’s spelling automatically  

 Click on OFFICE BUTTON and select the WORD OPTIONS  word option dialog box appears  

select PROOFING  when correcting spelling and grammar in word  Select Check Spelling As 

You Type check box. Then click OK.  

To check spelling of words with a wavy underline,  do this:  

 Right click an underlined word. A popup menu appears. It display a list of suggested and additional 

options 

 You have four choices for correcting the misspelled word these are: 

1. Select word from the list shown in the popup menu. 

2. Select ignore to leave the word as it is 

3. Select ignore all to ignore all occurrence of the word in your document 

4. Select add to add the word to the selected dictionary displayed in the spelling dialog box. 

5. Select Auto and choose the correct spelling to automatically correct the misspelled word. 

Spelling command for checking spelling & Grammar 

Select the word or select a document that you want to check for spelling. If you select nothing , 

word 2007 checks the entire document. 

1. Click the review tab 

2. Click proofing command 

3. Click the spelling and grammar or press F7 key. Select the correct word from the suggestions. 

4. Click on change/undo button. if you do not want to change click on cancel .  

8.1Testing Document Readability:  

Readability statistics would determine how easy to read you document. A document which is easy to 

read, communicates more clearly. 

Problem No. How to Display readability Statistics, do this 

1. Click on  Office Button  word option  Proofing Tab 

2. Click on check box show readability statistics  

3. Click on Ok button 

Note: After complete check & spelling grammar is completed than Readability Statistics dialog box is 

displayed on the screen. 

8.2 USING THESAURUS 
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Thesaurus is a word 2007 electronic database that contains English words with similar meaning. 

It defines selected words and offer alternative meaning. It defines selected words and offer alternative 

terms. When you are not sure of particular word's meaning, or you think you are using a particular 

word too often. 

Problem No. How to use thesaurus      Shift + F7 

1. Select word  

2. Click Review tab  Proofing command 

3. Click on Thesaurus button 

4. Select the Accurate Word 

5. Click the arrow next to accurate and then click Insert 

6. Close research task pane 

Q. what is AutoText feature in word 2007 and How is it done? 
In word 2007 the AutoText features was renamed. It is now called building blocks. The features is 

basically the same as AutoText in previous version but in but 2007 the building blocks have 

additional functionality 

You will save time effort by storing selected text and graphics including formatting that you see 

repeatedly 

AutoText can contain pictures and graphics or digitized signatures, graphics letterheads, logos, or 

symbols.  

Problem No Creating an AutoText Entry 

1. Select the Text, graphics, Table 

2. Click insert Tab 

3. Choose Quick Parts in text Group 

4. Click Save Selection to Quick Part Gallery... 

5. Creating New Building Blocks dialog box is displayed on the screen. 

6. Type Name : mywork 

7. Click on OK Button 

How to use AutoText Entry in Document 

1. Put the cursor in document 

2. click On Insert Tab → Quick Parts 

3. select your Text Entrées 

 

USING  AUTOCORRECT FEATURE 
The autocorrect feature in word 2007 recognizes typing mistakes and automatically corrects them. AutoCorrect 

feature can also be used to type long words. from an abbreviation automatically. For example, to automatically 

type the phrase not applicable, when you type the abbreviation na. 

Creating AutoCorrect Entries 
1. click the office button → Word Option  
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Word option dialog box appear 

2. click on Proofing Tab →Click Auto Correct option   

3. in the Replace : text box → type misspelled word 

4. in the With: Text Box →type correct Spelling word 

5. Click on Add Button 

6. Click on Ok Button 

Deleting AutoCorrect Entry 
1. click the office button → Word Option  

Word option dialog box appear 

2. click on Proofing Tab →Click Auto Correct option   

AutoCorrect Option Dialog Box is appear on the screen 

3. Select Entries you want to delete 

4. Click on Delete Button 

Using Word Count Feature 
the Word Count command totals the number of pages, word, characters, paragraphs, and line in a document. 

you can even choose to include footnotes and endnotes in the total. you can also find the word count in the 

status bar at the bottom of the window. 

To use the Word Count Feature 
1. click on the Review Tab → Click on Word Count under the Proofing Group 

2. Click on Close Button 

Student Assignment  
Q1. How can You check spelling in word?  what are the various option available to correct the wrong 

spelling? 

Q2. what is shortcut key to check spelling grammar 
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Chapter -9 Text Formatting 

Introduction  
 Formatting is the process of specifying how a document should appear when printed. Formatting can be 

divided into three categories: 

I. Character formatting 

II. Paragraph formatting  

III. Document formatting  

IV. Character formatting  terminology  

Characters 
characters are the letters, numerals, punctuation marks and special symbols (such as , , and ) that you 

type from the keyboard.  

Fonts and typefaces  
The terms fonts and typefaces are not actually the same but are used interchangeably. A font or typeface is 

defined as a collection of characters and symbols with a common appearance or design. Courier is an 

example of font.  

Font families 
A collection of all variations of a font is called a font family. For example, the Arial font family. This family 

includes Arial,  Arial black and Arial narrow characters.  

Monospaced and Proportionally spaced fonts 
1. Monospaced  (fixed in width) 

2. Proportionally spaced (made variable in width)  

Monospaced Fonts 
Fonts like Courier use the same amount of horizontal space on a line for each character. With a monospaced 

font a letter I take  the same amount of horizontal space as the letter W. monospaced fonts are used in 

legal documents. This is a an inefficient use of space and causes uneven looking words.   

Proportionally spaced fonts  
Proportionally spaced fonts fit narrow letters in less space. Arial and Times New Roman are examples of 

proportionally spaced fonts used in MS-WORD. 

Font sizes  
The size of the font is measured in points, and as the point size increases, the size of the letter also 

increases. One point equals 1/72th of an inch. 

Point size is the measure of a font’s height but not its width. Many font families are available in compressed 

and expanded forms as well as in normal widths.  

Serif and sans Serif fonts 
Fonts can be further categorized as : 

 Serif Fonts  : Serif fonts have fine lines that finish off the main strokes- for example at the bottom of 

the capital T or at the end of the T’s crossbar  for Example - Times New Roamn 

 Sans Serif Fonts: The “finishing strokes” called serifs, are absent in sans serif fonts. For Example such 

as Helvetica and Arial are greatly used in headlines, tables etc. 
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Types of fonts  
• It must appear on screen 

• It is printed on the printer 

To ensure that the fonts are displayed as they will print , do this  

1. Click the Office button →  word option →Click the Advanced 

2. Click on use Draft font check box under  show document content 

3. Click on  Ok     

Formatting characters  
Word 2007 enables the under mentioned character formatting option 

1. Font ,font style and font size changes  

2. Underline option , and color applications 

3. Applying inter font effects namely italics ,bold etc. 

4. Changing inter character spacing   

5. Applying animation effects 

Character Formatting using the Font Command  

You can print any font in any size from 1 to 1637 points. This corresponds to character heights ranging from 

approximately 1/72 of an inch to about 22 inches. 

 

To change the font of an existing text, do this  

1. Select the text you want to format  

2. Click the HOME tab →  Click on Font Launcher Dialog box 

Font Dialog Box Is Appear On The Screen 

3. Click on the font tab  

4. Do the following option - 

 Change Font Name - (Arial, Courier, Times New Roman) 

 Change Font Style - (Bold, italic, Regular) 

 Change Font Size - (8,9,10,12) 

 Underline Style → Click on Drop Down List and select underline below any one style: 

Effect  Appearance 

None Characters are not underline 

Single Both Words and space underline 

Words Only Only Words are underline 

Double  Both Words and space  double underline 

Dotted Both Words and space have a dotted line 

Thick Words are underlined with a Thick line 

Dash Words are underline with a dashed underline 

Dot Dot Dash The words are underlined with a dot dot and 
dashed line 

Wave The words are underline with wavy line. 

 

5. Select Font Color : (Red, Green, etc) 

6. Select Text Effect :  

Effect  Appearance 

Strikethrough Straight line through them, as  strike 

Double Strikethrough Straight double line through them, as  strike 

Superscript Characters are raised above the regular line of 
type and in a smaller point size. Example 102  
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Subscript  Characters are lowered below the regular line of 
type and in a smaller point size. Example H2O 

Shadow The Text appears with a sshhaaddooww 

Outline The Text appears with an  

Emboss The Text appear as eeemmmbbbooosssssseeeddd 

Engrave The Text appears, eeennngggrrraaavvveeeddd or imprinted on a 
page  

Small Caps Character are all uppercase, but initial caps are in 
the assigned point size and rest of the character 
are in a slightly smaller point size. SMALL CAPS 

All Caps The characters without actually changing the 
character themselves ALL CAPS 

Hidden Characters or text in a document which you do not 
want to be printed. The hidden text is displayed 
with a dotted underline  

 

Character spacing option  
 To customize the character spacing option ,do this  

In the Font Dialog box, click the character spacing tab.  

Group Option Description 

Spacing Normal Default spacing for the selected font. 

Expanded Space between characters are expanded 

Condensed Space between characters are condensed 

By: 
1 pt (default), or enter 

your own amount 
Number of points by which text is expanded or 
condensed or spacing option 

Position Normal Text is printed on the base line 

Raised 
Text is raised above the baseline by the increment you 
indicate in By box. 

By: 
3 pt (default), or enter a 

value 
Number of points by which text is raised or lowered for 
position option. 

Kerning for fonts 
8 pt(default) or enter a 

value 

Number or points by which specific combinations of 
characters are spaced. Only true type of Adobe type 
Manager fonts can be Kerned. 

 

Character formatting using the Ribbon 
1. To Change the Font Name (Times New Roman) 

Select paragraph → Click on Home Tab → Click on Font List Box → Select from List 

2. To Change the Font Size : (14 points) 

Select paragraph → Click on Home Tab → Click on Font Size Box → Select from List 

3. To Change the Font Style (Bold, italic, Underline) 

Select paragraph → Click on Home Tab → Click on Bold/ Italic / Underline  

4. To change the Font Color of Text (Green) 

Select paragraph → Click on Home Tab → Click on Font color Arrow Next → Select from List 

5. To highlight the font Color of Text : (Gray) 

Select paragraph → Click on Home Tab → Click on Highlight Color  Arrow Next  → Select from List 
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How to change with Pop Up Toolbar: 
1. Select The type Text Paragraph 

2. Move the Cursor Right hand side 

3. A Popup bar will be displayed on the screen 

4. Click on font Name, Font Size ( select Name & Size) , Bold, italic, underline, and color   

Applying Character Formatting Using the Keyboard 

Format Shortcut 
Bold Ctrl+B 

Italic Ctrl+I 

Single Underline Ctrl+U 

Word Underline Ctrl+Shift+W 

Double Underline Ctrl+Shift+D 

SMALL CAPS Ctrl+ Shift+K 

ALL CAPS Ctrl+Shift+A 

Hidden Text Ctrl+Shift+H 

Superscript Ctr+Shift+= 

Subscripts Ctrl+= 

Copy Formatting Ctrl+Shift+C 

Past Formatting Ctrl+Shift+V 

Remove Formatting Ctrl+Spacebar 

Change Case of Letter Shift+F3 

Font Ctrl+Shift+F 

Symbol Font  Ctrl+Shift+Q 

Point Size Ctrl+Shift+P 

Increase Font Size Ctrl+Shift+> 

Decrease Font Size Ctrl+Shift+< 

Increase font size up one point Ctrl+] 

Decrease font size down on point Ctrl+[ 

To Copy Text  Ctrl+C 

To Paste Text Ctrl+V 

 

What is Kerning? 
 Kerning is the process by which the spacing between the narrow and wide characters is automatically 

reduced when they appear together. For example, TW. Here the space between the character T and W 

appears very close. 

Control Kerning Automatically 
1. Click the Font Dialog box Launcher 

2. Click the CHARACTER spacing tab 

3. Click the kerning check box to put the kerning option into operation. The option is on when a check 

mark () appears in the check box. 

4. Click OK to save the setting or Cancel to restore the previous setting. 

 

Removing Character Formatting 
1. Select the character whose formatting you wash to remove. 
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2. Press Ctrl + Spacebar. 

  Word does not remove character formats that are a part of the paragraph style of the text, using Ctrl+ 

spacebar key combinations 

 

Formatting Paragraphs:  

A Paragraph can have the following characteristics: 

o Alignment 

o Indents 

o Line spacing  

o space before and after the paragraph 

 

Alignment: The attribute Alignment of a paragraph refers to the position of the main document text on the 

page. Different alignment positions in word are given in below table.  

 

Problem No   How to change Paragraph Alignment by using Keyboard? 

Left Alignment (Ctrl+L) Aligns the text at the left margin and makes a zigzag right margin 

Right Alignment (Ctrl+R) Aligns the text at the Right margin and makes a zigzag Left margin 

Centre Alignment (Ctrl+E) 
Centers text between the left and right margin on the centre line. In This case both 
the margins are zigzag. 

Justify (Ctrl+J) Aligns the text at both the margins by increasing the spacing between the words 

 

Indents 
Indents are the white space added to the margins and thus decreasing the text area for paragraphs. So, 

when you have a "right margin and you want to add a right indent of 1.0" your text will be printed 2.0" from 

the right edge of the paper. Once you change the indent, each new paragraph you start by pressing the 

Enter key will maintain the same indentation setting until you change it. 

Problem No   How to Increase or Decrease Indent by Using Command? 

1. Select Sentence or Paragraph 

2. Click on Home Tab → Click on Increase / Decrease Indent 

Line Spacing 
Line spacing in a paragraph means the amount of space between the lines. Word offers the line spacing 

options as given Table. 

Option Description 
Single spacing No blank line space appears between the lines of text. 

Double spacing A blank line space appears between the lines of text 

1 1/2 spacing Half the height of one line space of text appears between the lines of text. 

Exact line height Specify the space you want between the lines. 

 

Problem No   How to Increase or Decrease Line Spacing by Using Command? 

1. Select Sentence or Paragraph 

2. Click on Home Tab → Click & Select  on Line Space  
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Problem No   How to Increase or Decrease Line Spacing by Using Keyboard? 

1. Select Sentence or Paragraph 

2. Press Ctrl +1 ( To Single Line Space ), Ctrl+2 (To Double Line Space), Ctrl+5  (To one and Half Line 

space) 

Formatting Paragraph Using Shortcut Keys 

To Format paragraphs Alignment by Using Shortcut Key 

1.  Left (Ctrl+L 

2.  Right Ctrl+R 

3.  Center Ctrl+E 

4. Justify Ctrl+J 

To indent Paragraph using the Keyboard Shortcut key 

5.  Left Indent Ctrl+M 

6. Remove Left Indent Ctrl+Shift+M 

7. Creating Hanging Indent Ctrl+T 

8. Reducing Hanging Indent Ctrl+Shift+T 

9. Remove Paragraph Formatting Ctrl+Q 

To Change the Line spacing using the Keyboard Shortcut Key 

10. To Create Single spaced Lines Ctrl+1 

11. Create Double Spaced Lines Ctrl+2 

12. Create One and Half line spaces Ctrl+5 

13. Add or Remove one line space  Ctrl+0 

 

Appling Borders and Shading: 
A border may be a box around a paragraph from all sides. It could be a line that set a paragraph off on one or 

more sides. A border can include shading and box.  

If a group of paragraphs is formatted with a box around them and you  

 

 

Applying Border to a paragraph: 

1. Position the insertion point 

2. Click on Home Tab  Click on Boarder And Shading  

Border and Shading dialog box appear on the screen 
3.  Choose the Setting any one  

4. Choose the Style 

5. Choose the Border color 

6. Select the Width  

7. See the Preview  

8. Click on Ok Button 

Applying Shading to a paragraph: 

1. Select the Paragraph 

2. Click on Home Tab Click on Boarder And Shading  

Border and Shading dialog box appear on the screen 

3. Click on Shading Tab 
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4. Click on Fill Drop Down List 

5. Select Pattern And Style 

Formatting Text and Paragraph Quickly 
1. Select The Text 

2. Click on Home Tab  Select Style any one such as Heading 1, heading2 and Tilte 

 

Student Assignment: 

Q1. Define and Explain how to adjust "Line Spacing " and  " Paragraph spacing" in word document 

Ans :  Line spacing : the amount space from the bottom of one line of text to the bottom of the next line . line 

spacing determine the amount of vertical space between line of text. Microsoft word uses single line spacing by 

default. The line spacing you select will affect all lines of text in the selected paragraph:  

Steps: 

1. Select paragraph 

2. Click on Home Tab →Click on Paragraph launcher Button arrow 

3. Select Line spacing :  Single,Double,1  1/2 , Multiple 

Paragraph Spacing : The  definition of term paragraph in English language is " a series of related sentence". In 

Microsoft word, a paragraph is a distinct unit of information that has its own formatting characteristics such as 

alignment, spacing and styles.  

1. Select the paragraph 

2. Click on Home Tab → Click on Paragraph launcher Button arrow 

3. Choose Indent and spacing Tab → Select Space Required Before or After the paragraph 

4. Click on Ok Button 
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Chapter -10 Document Formatting 

INTRODUCTION 
 Formatting a document in Word 2007 is the process of changing the appearance of a document as 

a whole .It involves the length of the printed page, left margin, right margin, etc. All such procedure 

is explained in this Chapter.  

Working with section  
Organizing documents in section makes it possible to change header and footer for easy reference 

.Section make it possible to customize page number within chapter. Pages within chapter might 

contain chapter-related numbers that restart at the beginning of each chapter (1-1,2-1,and so 

on).You can also use different page-numbering styles in each section of a document.   

Problem No1  How To insert a section break, do this  

1. Position the insertion point where you want to the section break to they occur. 

2. In the Page Layout  tab of Page Setup group, in the top right corner 

3. Click Insert Page and Section Break command.  

4. Choose an option from the following: 

Option Description 

Next page This selection would start the new section on a pew page. 

Even page This section would start a section on an even numbered page  (i.e. left hand page) 

Continuous This section would Insert a section break without starting it on a new page. 

Odd page This selection would start a section on an odd numbered page (i.e. on the right hand 
page. 

A section insertion places a double-dotted, non printing line containing the words End of section at 

the insertion point on your screen  

Problem No2  Deleting Section Breaks  

Selection a section break and press the Backspace or Delete key . Text after the removed section 

break will take on the characteristic of the preceding text .It may take a moment for Word 2007 to 

reformat and repaginate the document. 

PAGE SETUP OPTION  
Page layout option includes: 

o Margin 

o Vertical Alignment on the page 

o Page and paragraph breaks 

o Section breaks 

o Page numbers 

o Headers and footers 

o Paper size 

o Orientation and the paper source  

o Document margins and orientation  
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The default margins of word 2007 are 1 inch at the top and bottom each and 1 inch on the left 

and right. 

 Note that in outline view you do not see the margins. However you can see the space between 

them in print layout view and you can see the page as it will print. Always select the print layout 

view if you want to see headers, footer, page number, footnotes etc.  

Problem No 3 How to set margins with the page setup command, do this 

1. Click on  Page Layout   

2. Click the Right Corner Arrow  Page Setup. The page setup dialog box appears. 

3. Click the Margins Tab property sheet as shown in……….  

Option Description 
Top: Select or type out the desired margin from the top of the page  

Bottom: Select or type out the desired margin from the bottom of the page 

Left: Select or type out the desired margin from the left of the page 

Right: Select or type out the desired margin from the right of the page 

Gutter Select or type of the gutter space as required Gutter is the extra space added to the 
margins to leave the space for binding the document 

Orientation  Select Between Portrait (Vertical)  or Landscape (Horizontal) page settings 

 

4. in the pages Area, Select the Multiple Pages List - Mirrer Margins 

5. In the Apply To: Choose the Portion of the document from where you want to apply new 

settings. 

-------- SET Paper Size --------- 

6. Click on Paper Tab  

7. Select Paper Size From Drop Down List : Letter  

8. Click on Ok Button 

Problem No4. How To set margins in print preview do this: 

1. If the rulers are not visible, Click the ruler icon 

2. Position the mouse pointer on a ruler's edge. 

3. The  pointer will change to a two-headed arrow. 

4. Drag pointer to adjust the margin. 

 

Paper size and Page Orientation 

You can also select one of the two types of page orientations namely portrait (vertical) and 

Landscape (Horizontal). You can change the paper size and page orientation for a section or for the 

entire document.  

 

Problem No5. How to set Paper Size and Page Orientation by Using Page 

Layout  

1. Click on Page Layout Tab 

2. Click on Size Arrow → Select Paper Size 

3. Click On Orientation → Select Any one (Portrait or Landscape)  
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Page Breaks:  page Breaks the places in  your document where one page would end and a new 

page would begging. You can see page breaks in all views prior to printing. 

Problem No 6 How to Inserting page breaks…….  

1. Put cursor you want to page break. 

2. Click the INSERT Tab 

3. Click On page break.    

Problem No 7 Moving and deleting manually inserted page breaks.  

1. Select the page break as you select text. 

2. Now press the DELETE key. The pages break in removed.  

Headers and footers  
Header and footer is the text or graphics which is printed at the top and bottom of every page respectively in a 

document. A header is printed in the top margin whereas footer is printed in the bottom margin.   

Problem No 8  How to Inserting header and footer  

1. Click the INSERT tab 

2. Click Header & Footer group  

3. Select Header / Footer Style gallery 

4. Type The Text Header / Footer  and   company logo 

5. Click on Close Header/ Footer. 

 

Inserting and formatting the page numbers  
You can add page numbers, which are associated with headers and footers, to the top, the bottom or 

in the margins of documents  

Problem No 9  How to Inserting Page Numbers & Format Number 

1. Click on INSERT Tab 

2. Click on Page Number from Header/ Footer Group 

3. Select Page Number Style. 

4. Click on Format Page Number → Select Page Number Style. 

Setting up columns  

Word 2007 enables you to create columns of equal or unequal width. If need be, you can include a 

vertical line between columns. You can include different numbers or styles of column different 

section of your document, as is used in a magazine.  

 Word 2007 determines how many columns you can have on a page based on following three 

factors: 

o  page width 

o Margin width 

o Size and spacing of columns. 
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 In word 2007 columns cannot be less than .5” (Half an inch) wide. Columns have the 

length of the current section or of the current page if there are no sections.  

Problem No 10 How to Creating Column of Unequal Width 

1. Click on Page Layout Tab 

2. Click on Column arrow from Page Setup Group 

3. Click on Customize column 

4. Select And click on This point to Forward 

5. Select Column Number 

6. Click on Line Between ( if you wish) 

7. Click on Ok button 

 

Inserting Footnotes and Endnotes 

Word 2007 has footnote feature that enable you to enter, edit and view footnotes/ endnotes in a 

variety of formats. The only difference between footnotes and endnotes is that, the footnotes appear 

at the bottom of page and endnotes appear at the end of the section or document. 

Problem No 11 How to Insert Footnote/Endnote in document  

1. Place cursor on word which you want to refer note 

2. Click on Reference Tab →Click on Insert Footnote / Endnote  

 Or Press Alt+Ctrl+F keys  together for Footnote  

 Or Press Alt+Ctrl+D keys  together for Endnote 

 

  Inserting Symbols and Equations: 

Some documents require characters not found on a standard keyboard. These characters might include 

signs such as copyright © or registered ® symbols. You want to add arrow (such as ). You can 

insert mathematical symbol such as     is a called MS Reference Spatiality. 

Problem No 12 How to Insert Symbols in document 

1. Put the cursor where you want to add symbol 

2. Click on insert Tab Symbol  

Symbol Dialog Box is displayed on the screen 

3. Select Font from Drop Down List 

4. Select Symbol and click on Insert Button  Click on Close button 

Problem No 13 How to Insert Equation in document 

1. Put the cursor where you want to add symbol 

2. Click on Insert Tab  Equation  insert  New Equation 

3. Type C then on the Design Contextual tab  

4. Select 𝜋 symbol 

5. Type * singh 

6. Type D here 

                    C=π*d 
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Chapter -11 Document & Template 
Wizard 

INTRODUCTION: 
A template is a form of document specific type that creates a copy of itself when you open it. A 

template is a file that stores text, characters and paragraphs styles, page formatting and elements such 

as graphics for use as a pattern in creating other documents. template can be a .dotx, .dotm and dot 

file. 

Working with a Template: 
Word 2007 comes with a set of predefined templates that you can use to create documents. Unless you specify 

it all new documents are based on the normal document template. Normal template defines a plain style such 

as paragraph styles for regular text paragraphs a title and different levels of headings. The styles from the 

normal template appear in the styles gallery on the home tab when you create a new blank document.  

Problem No1.   How to Create A New Template  

1. Click on Office Button  New Option  

New document Dialog Box is displayed on the screen. 

2. Click on Installed Template 

3. Select any one style such as oriel letter 

4. Click on Create Button 

5. Edit and Type  format 

6. Click on Save Button from Quick access toolbar 

7. Type The Name 

8. Click on Save Button 

 Using wizards 

In the previous version of word 2007, a wizard is a part of a program that guides you through certain 

steps for example envelope wizard letter wizard etc these wizards are replaced by word 2007 

templates available by office online. 

Creating newsletter wizard 

The templates of word 2007 are available on Microsoft office online and can easily be customized to 

make an effective newsletter that suits your needs. It takes you step-by-step the whole process of 

creating a letter. For example, newsletter template. 

  Problem No2.   How to Create Wizard  

1. Click on Office Button  New Option  

2. In the Search Field of Template Window type Wizard  

3. The available results will appear in center pane for example , newsletter Letter Wizard, 

Calendar Wizard, Resume Wizard etc.  
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4. Select the desired Wizard  

5. Click on Download button 

6. Click Next >  

7. The second step to select the desired Style & color of newsletter  

8. Click Next > 

9. The Third step to Title & Contents of Newletter 

10. Click Next > 

11. The fourth steps to select Mailing Level 

12. Click Next> 

13. The fifth steps to click Finish Button 

14. Now you can select and apply the desired style such as Heading, Body text, folio etc.  

15. After completing the letter, click Office button  Save  

16. Save the file as Word template  

17. The download template file save in the My templates folder 

18. Whenever you want to open the template file, click the Office button  New  

19. Under Template click My Template 

20. Select The desired downloaded template file and make changes  

 

Student Assignment 

 

Make a template for the bio – data with the following format 

Bio Data 

Name      : 

Father’s Name    : 

Date of Birth    : 

Address     :  

Educational Qualification  : 

Sr No Qualification Board Percentage 

    
 
 

Work Experience: 
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Chapter -12 Using Table & Chart  

12.1 INTRODUCTION  
Word 2007 enables you to create tables and charts in a document. In this chapter we will discuss how to create 

charts and tabular matter using tables and tabs.  

 We use the table features in built in word 2007. it offers choice for creating text in the form of table.  

12.2 Working with tables  

You should use tables to create documents, such as forms financial reports, catalogs and bio data. Tables consist 

of horizontal rows and vertical column. You type in the areas called cells formed by intersection of rows and 

columns. Cells can contain text numbers or graphics. 

You can even control the Size, shape, and appearance of the cells and use border and shading features. You can 

insert and delete rows and column in a table  

 A new feature called the table wizard helps you to automate table creation.  

Problem No1   How To Creating A Table Using Table Option  

1. Put Cursor In Document 

2. Click on Insert Tab   Table  Insert Table  

INSERT TABLE DIALOG BOX IS DISPLAYED ON THE SCREEN 

3. Enter No of Column & Rows You Desire 

4. Click on OK Button 

Problem No2    How To Move Within Table Using The Keyboard 

 To Move Right and Down  Cell  Press TAB key 

 To Move Left or Previous Cell Press  Shift + Tab Key 

12.3 Selecting Text in a table  

You can select characters words and other items in a table cell using mouse or keyboard. In addition word 2007 

provides tables-specific selection tools that allow you to choose cell, entire rows, columns or areas as per your 

need.  

Problem No3     How to Select Cell by using Mouse & Command 

By Using Mouse 

 Click on Cell Selection Bar ( area between text and cell edge) 

By Using Command  

 Click on Cell  Click On Layout Tab   Select  Select Cell  

Problem No4    How to Select Column by using Mouse & Command 

By Using Mouse 

 Move the Mouse Pointer to the area at the top of a column called the column selection bar & 

Click on Column Heading 

By Using Command  

 Click on Cell  Click On Layout Tab   Select  Select Column 

Problem No5    How to Select Rows by using Mouse & Command 
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By Using Mouse 

 By clicking cell selection Bar  

By Using Command  

 Click on Cell  Click On Layout Tab   Select  Select Rows 

Problem No 6   Selecting Adjacent Groups of Cells  

1. Drag through the cells or click in one cell and press Shift + Click in the others.  

Problem No 7    Selecting the whole table  

1. Press down the alt key and double click anywhere in the table.  

 

Problem No 8    How To Insert Row, Column & Cell  

Method 1st:  

1. Put the cursor in cell 

2. Right click on Cell  Context Menu Displayed  Insert  Select Row/ Column/ Cell  

Method 2nd: 

1. Put the cursor in cell 

2. Click on Layout Tab →Click on Insert Option → Select Row/Column/ Cell 

 

Problem No 9          How To Change Column Width   

1. The pointer will change shape to a double arrow. Drag the column width maker. Watch the dotted line 

as well as the ruler setting then release the mouse button when it reaches the desired width. 

2. Or click table column width scroll box, to change the table column width in the cell size. 

a. If you hold down the (Shift) key while dragging the column to the right does not change size 

while the table’s overall width increases. 

b. If you hold down (Ctrl) key while dragging mouse all columns to the right changes size but the 

tables overall width will not change. Thus the width of the columns on the rights will only 

change.  

Problem No 10    How To Merge Cell & Split Cell  

 To Merge Cells, do this 

1. Select the cells 

2. Click on Layout Tab → Click on Merge Cell 

 To Split (Unmerge) cells, do this: 

1. Click On Cell 

2. Click on Layout Tab → Click on Split Cell  

3. Type on Number of column / Row  

 

Problem No 11    Convert  text to a table & Table To Text  

 To convert text to table do this: 

1. Select the text that you want to convert into a table 

2. Click inserts tab → Table, pill-down menu appears 

3. Click the convert text to table …. Command 

4. In convert text to table dialog box, in the separate text at section select the radio button such as 

paragraph tabs or commas. 
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5. You must choose the option that corresponds to the way you divided you text  

6. Click OK. Word 2007 converts to converts into a table.  

 To convert table to text, do this:  

1. Select the Table that you want to convert into a text. 

2. Click the Layout table to text… command 

3. In convert table to text dialog box in the separate text at section select the radio button such as 

paragraphs tabs or commas. 

4. Click OK. Word 2007 converts your table into text.  

Problem No 12   FORMATTING  TABLES   STYLES  

With word 2007, you can quickly get started by creating a quick table, a preformatted table with sample data 

that you can customize it. 

1. TO FORMAT A TABLES STYLE, DO THIS:  

2. SELECT THE ENTIRE TABLE by pressing at the top corner of the arrow in the table or press (Alt + S) on the 

numeric keypad with (Num lock) off. 

3. Click DESIGN contextual tab. In the Table Style options group, click or clear CHECK BOXES, SUCH AS 

HEADER ROW OR BANDED COLUMNS. 

4. Click the more buttons on the table style group. 

5. Click a table Desired Style. Word 2007 format your table according to the style you select.  

Problem No 13   TO  SORT  A  TABLE 

a. Position the Insertion Point in the table you wish to sort. Alternatively, select the cells you want to sort. 

b. Click the Layout contextual tab → click on SORT in the Data group. 

The sort dialog box appears… 

a. If you have labels at the top of your tables then in the my list has section click header row radio 

button  

b. There will be up to three drop-down lists containing the column labels or column numbers (1,2, 

and 3) 

c. Specify the Sort Order by choosing the desired columns for each sort level. 

d. Choose a Sort Order for each column. 

c. Specify if the data in each column are text numbers or date by choose from the drop-down type: lists. 

d. Select either the ascending or descending radio button. 

e. Click OK. Word 2007 will sort the table based on the data n the column you selected.  

 

Problem No 14   → Adding   Borders To A Table 

1. Borders can emphasize parts of your table such as  particular row or column. To add a border to a table 

you need to define the following: 

– Where you want the border to appear 

– Border color 

– Border line style 

– Border line thickness  

2. TO ADD A BORDER, DO THIS:  

– Move the cursor to the row, column cell or table where you want to add borders. 

– Click design contextual tab of table styles group, click pen color. As shown in the …… 

– Click a color for your border 

– Click the line style list box. 

– Click a desired line style. 
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– Click the line weight list box 

– Click a desired line weight  

Problem No 15   → SETTING  CUSTOM  TAB  STOPS  

1. With the ruler in view click the button at the left edge of the horizontal ruler repeatedly until it shows 

the icon for the tab stop you want to insert. Tabs are left right decimal and center. 

2. Click on the ruler where you want to position a tab stop. If you make a mistake drag the stop off the 

ruler and try again 

3. When you type press the tab key to move the insertion point to the new tab position.  

 TO MOVE A TAB STOP DO THIS:  

• To set tabs using the tabs dialog box do this: 

1. Position the INSERTION POINT in paragraph for which you want to insert tab. 

2. Click the Home tab. Click Paragraph Launcher. 

3. In paragraph dialog box, click Tabs… button. Tab dialog box  

4. In the TAB STOP position box enter the position where you want to insert the tab stop. 

5. In the alignment area select the type of tab you want to insert. 

  

To insert a chart using data in word 2007 document do this:  

1. Move the insertion point where you want where you want to insert a hart 

2. Click the INSERT TAB in the ILLUSTRATIONS group, click the Chart button. 

• The insert chart dialog box opens. In the gallery on the right under column choose desired type of 

column you want. Click the OK.  

 

Assignment No1: 

Insert a table. The table should have 5 columns. The auto behavior should be ‘Fixed column width’. The 

following report has to be created in the table 

Sr.No Name Basic Pay Designation Department 

1 Rahul Roy 10000/- MD Marketting 

2 Ritu Garg 12000/- AD Sales 

3 Mohit 8000/- Manager Sales 

4 Rakesh 9000/- Senior Manager HR 

 

• Heading should have font Size of 18, color should be blue and font should be bold. 

• The data should have a font size of 12, color should be red and font should be italic. 

• Insert a new row between 3 & 4 and type the data and reorder the Sr. No column. 

 

Take Help of Faculty & Type Tips Here: 

Assignment No2: 

Create a table in word as shown below: 

Roll No Name Marks in Physics Marks in 
Chemistry 

Total marks 

1 Ritu 80 70  

2 Rohit 70 80  
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3 Amit 60 50  

4 Rakesh 40 60  

5 Teena 45 70  

6 Garima 80 80  

Do the following: 

a. In the total marks column, entries should be calculated using the formulas and it is the sum of 

marks in physics and marks in chemistry 

b. Insert a new row at the end of the table and also find grand total using formula 

c. Sort the table based on total marks 

d. The data and heading should be center aligned 

e. Heading should be bold and underlined 
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Chapter -13 Page Setup & Printing 

Introduction  
It is always advisable to save a file before you print it. Occasion ally printing problems can lock up your computer 

and you might lose any unsaved changes if you are forced to reboot the pc (Personal computer)  

Previewing and printing a document  
Before you print a document you may want to check how it will look on paper by previewing it. Previewing is 

essential for multipage document but is helpful even for one page document also. To preview a document you 

click the office button point to print and then click print preview. This view shows exactly how each page of the 

document will look when printed.  

Setting printer options  
Windows operating system manages details of setting up a printer. However a window leaves three tasks for 

use: 

1. Selecting The Printer you want to use in word 2007 
2. Installing the Printer if not available in the list of windows printers. 
3. Changing the Printer Setup for special printing needs  
 Most of the printer options are set by word 2007 depending upon the printer selected by you. All the 

same many options are available to you so that you can customize the printing options  as per your 

requirement. 

The printing options in word 2007 can be classified in two categories. 

 To set printer specific options do this:  

• Click the OFFICE button and choose print or press (Ctrl + Shift +F12) keys together. 
• Select a PRINTER from the name: drop-down list 
• Click the PROPERTIES button in the print dialog box.  
• PRINTING the current document  

 
TO PRINT A COPY OF THE DOCUMENT DO THIS- 

1. Open the document you want to print. 
2. Click the FILE menu and choose Print .. Or press Ctrl + Shift+F2 keys. The print dialog box appears,. 
3. Click Ok. 

Note : The print dialog box closes and a print icon in the status bar displays the process of the print job.  
 
TO CANCEL PRINTING DO THIS:  

1. While the print icon is displayed press ESC 

2. When the printer icon appears in the taskbar, you can Double-Click it to open the printer folder. 

3. Select the Document you want to Cancel printing and then choose document, cancel printing. If the 

printer icon is no longer displayed in the windows taskbar, word may have already sent the print job to 

the printer.  

 

USING PRINT PREVIEW FEATURE  
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• To preview the document do this: 

– Click the FILE MENU and choose the PRINT PREVIEW or click The Print Preview button on the 

standard toolbar. The screen changes to the one as seen in….. 

The various elements an option available in the print preview mode are explained 

in1 … 
In print preview you also have access to the normal page layout and outline icons at the left corner of the 

horizontal scroll bar. Clicking any of these buttons closes the preview screen and displays the document in the 

view ode you selected. 

To print only a document’s hidden information without printing the document do this:  

1. Click the FILE menu and choose PRINT. 
2. Click the Tools menu and choose options…. The options dialog box appears click the tab. 
3. In include with document section select one of the options  
4. Click OK.  

 

Printing document to a file  
• The feature enables you to print a document from a printer connected to a computer that does not have 

word installed. You can print the document to a printer file and take this document as a printer file with 

you to be printed later. 

 The printer file you create must be made for the printer you will actually print on. 

1. To print to a file ensure that word is setup for the printer to be used to print the file do this:  

2. Click the FILE and choose print 

3. Select the Print To File Option  

4.  Click ok. 

The print to file dialog box appears. 

5. Change to the Folder where you want to SAVE the printer file.  

6. In the File Name box, type the name of the file to contain the document.  

7. Then choose OK. 

 When you want to resume printing to your printer deselect the print to file option in the print dialog box.  

Shrinking a document to fit a page  
 You can undo the effects of shrinking if you lick the Undo tool. However after you save the document you 

cannot undo shrink to fit. Assignment: 

Use the document earlier saved and performs the page setting as follows: 

Top Margin  1.3”   Gutter Margin  1.2”  Orientation  Landscape 

Bottom Margin 1.4”  Header  0.7”  

Left Margin  1.30”  Footer   0.7”  

Right Margin  1.30”  Paper Size  executive   
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Chapter- 14 Using Mail Merge Document 

Using mail merge  
Mail merge is a mass-mailing facility using e-mail methods or otherwise that takes names address and pertinent 

facts about recipient and merges the information into the form of a letter.  

Data source and main document  
When you open the main document in word 2007 it brings with it the associated data source with which it was 

saved last. If you use a different main document, then remember to attach it with a new data source that you 

may want to use.  

Creating a Mail Merged letter  
The best way to learn how to create and print a merged document is to consider a practical example. This is 

described in the following sections.  

1. Creating a document for mail merge  
2. For mail merge you need to do the following: 

 Create a data source 
 Create main document 
 Insert fields into the main document 
 Check for design and data entry errors 
 Merge the data source document and the main document band finally print merged document.  

Staring mail merge  
1. TO USE THE MAIL MERGE HELPER DO THIS: 

 FIRST CREATE A BLANK DOCUMENT. 

 Click the Mailing Tabs in the Start Mail Merge Group and click down pointing arrow. A list 
appears as seen in figure.  

2. CREATING MAIN DOCUMENT, DO THIS  

 Click the Mailings Tab in the Start Mail Merge Group and click down pointing arrow and select 
Step Be Step Mail Merge Wizard… 

 On the right hand side the Mail Merge Task Pane Box appears as seen in figure 14.2 showing 1 
of the wizard’s six steps.  

3. Steps involved in mail merge  

1. Open or Create A Main Document, which contains the generic information that you want to repeat 
in each form letter, mailing label envelopes or catalog. 

2. Open Or Create Data Source which contains the data that varies in the merged document. 
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3. In the mail document Insert Merge Fields, which are placeholders that tell Microsoft word 
where to insert data from the data source? 

4. Merge Data From The Data Source Into The Main Document. Each row in the data source produces 
an individual form letter mailing label or catalog item. You can send the merged document directly 
to a printer or e-mail addresses or fax numbers. Or you can collect the merged documents into a 
new document so you can review and print them later.  

5. Printing The Merged Letters  

If you want to print the letters make sure that the printer is switched on and is in ready to print mode. Then click 

the print…. Under merge, Ok click the finish & merge group. Click down pointing arrow and choose Print 

document. The Merge to Printer dialog box appears. Select the records and Click OK.  

Assignment: 

 Below is given a letter and some addresses, this letter is to be sent to all these addresses so use mail merge 

option to do so 

Addresses are : 

1) Amit 

H.No 424 Sector 8D 

Chandigarh 

2) Rohit 

H.No 4444 Sector 125C 

Chandigarh 

3) Jyoti 

H.No 550, Sector 16A 

Chandigarh 

The Letter is : 

To 

<<Name>> 

<<Address>> 

Dear <<Name>> 

 You are called for an interview on the <<Date>> at 9:00 A.M with your original documents at Shyine 

Hotel Delhi. 

Your Sicerely 

ABC Limited 

Phase – 7 

Mohali 

Solution: 

1. Open Blank document in word 
2. Click on Mailing Tab → Click on Start Mail Merge Arrow from Start Mail Merge Group 
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3. Click on Step By Step Mail Merge Wizard from List 
Mail Merge Task Pane is displayed on Right Hand Screen 

1. Select Document Type - 
Q. what type of document are you working on ? 
Ans – Select Letter & Click on Next(Starting Document) 

2. Select Starting Document 
Q. How do you want to setup your letter ? 
Ans – Select Use the current Document & Click on Next (Select Recipients) 

3. Select Recipient: 
Ans: - Select Type a new List → Click On Create Button 
The New Address List Dialog Box Is Displayed On The Screen 
To Delete Some Field Click on Customize Button 
Select Field and click on Delete Button 
Click On Ok Button 
Type The Entry Field → Click on Ok Button → Click o Save Button →Click on Ok Button 
Click on Next (Write your Letter ) 

4. Write your Letter   
if you have not already done so , write your letter now. 
Put the cursor on document Click on Address Block → Click on Nex button (Preview your Letters) 

5. Preview your Letter  Click on Next (Complete the Merge) 
6. Click on Print or Edit Individual Letter 

Working with graphics  

Graphics can include a wide variety of images including pictures and drawing objects. Pictures and graphics that 

have been created outside word 2007 namely a scanned photograph, clip art that are created within word a 

shape a diagram a line or word art text.  You can use the buttons on the insert tab to insert pictures and draw 

different kinds of object. Word 2007 lets you draw, place, resize, reposition and format all above type of 

graphics.  
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Chapter- 15 Introduction TO Excel 

Electronic Spreadsheet  
 An Electronic spreadsheet application accept data value and marks relationship between the data 

value in a tabular format consisting of rows and columns. It also manipulates data in a desired 
format the first spreadsheet available for the PC was VisiCalc which was a best seller. VisiCalc was 
followed by Lotus 1-23. Finally, the largest selling spreadsheet program is Excel 2007. 
Electronic spreadsheet is a software package which accept data in a tabular form (rows & 
columns),shows data in a tabular form and server many function to perform calculations. 

Spreadsheet Terminology  
 When you are a Spreadsheet package you have to know some Spreadsheet terminology. Some 

such terms are given in the following paragraphs. 

Workbook 
 A workbook is a collection of many worksheet. In a single workbook you can store information in 

an organized manner. By default a workbook open with three worksheet and it can contain a 
maximum of 255 worksheets. 

Worksheet 
 A worksheet is a sheet made up of rows and column. It is used for planning a project or financial 

document of an organization. Worksheet refers to the actual document you create by using the 
spreadsheet refers to the actual document is always stored in a workbook. 

 Chart sheet  
 Chart sheet is a separate sheet in a workbook that contains only graphs or charts. It is useful 

when you want to see a chart or tabular data separated from other type of data. 

Row 
 A Row is a Horizontal block of cells that runs through the entire width of the worksheet. The rows 

are numbered from top to bottom along the left edge of the worksheet. The first row is 
numbered 1, the second 2, and so on. There can be a maximum of 1,048,576 Row in an excel 
2007 worksheet. 

Column 
 A Column is a vertical block of cells that runs through the entire worksheet. A worksheet contains 

16,384(A to XFD)columns. The first column is A, the second is B and so on until you reach Z. then 
comes column AA through XFD is the last (or rightmost) column of the worksheet, XFD is the 
16,384th column. 

Cell 
 A cell is the intersection of row and a column. For Ex, the uppermost cell is A1 (column A, row 1). 

Cell G9 is the intersection of column G, row 9. when you select a cell by clicking it the with the 
mouse, or moving to it using the keyboard, it becomes the active cell.  

Formula 
 Formula are equation that perform calculation on values in you worksheet. It is an order of 

values, names, cell references, functions and operators in a cell that together give a new values. A 
formula always begins with=(equal) sign. 

Function 
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 Function are predefined formulas that takes value or value, perform complex calculation 
by using a specific value in a particular other to give a result. Functions are used to simplify the 
formulas that perform lengthy or complex calculations.  

Working with Spreadsheet  
 In Excel 2007, each workbook can contain many worksheets. This sheet may also contain charts, 

macros, etc. sheet may contain different type of information but all data or information is related 
to each other. 

 Generally, spreadsheet is a software tool and worksheet is a work file created with spreadsheet 
software. But sometimes, worksheet is also called a spreadsheet. 

Advantages of Spreadsheet  
1. In Excel 2007, many built-in functions do the complex calculations easily. 
2. Large volume of data can be handled easily. 
3. A graphical representation of data is possible. With the help of graph and charts data can be 

interpreted easily. 
4. Useful information can be imported or exported form/to other software package such  as Word 

and PowerPoint. 
5. If entire are changed, then formulas automatically calculate the new results.  

Disadvantages of Spreadsheet  
1. It requires very large memory of a perform complicated calculations and to plot graphs. 
2. It has limit number of row and column in one worksheet. If user has more data to enter he has to 

shift data in another worksheet that may create confusion. 
3. It requires skilled user because small mistake in formula will give absurd results. 

Applications of spreadsheet 
 Spreadsheet are mainly used to solve complex calculation easily. They can be used for graphical 

representation of large volume of data so, spreadsheet are used in the following applications:  
1. Budgeting and forecasting. 
2. Scientific research. 
3. Financial accounting. 
4. Income tax and sales tax applications. 
5. Annual reports. 
6. Portfolio analysis. 
7. Determine the break even points in sales. 
8.  sales and purchases application or in business applications. 
9. Statistical analysis of database. 
10. Job estimation and cost accounting. 

STARTING Excel 2007 
 To start Excel 2007, do this 

 Click the Start button on the taskbar → All Program → Click Microsoft Office and then  Excel 
2007. 

Title Bar 
 At the top of an Excel 2007 window, there is the title bar. The left edge of this bar has MS-Office 

button next to which the name of the open document is displayed. On the right edge of the title 
bar, the minimize, restore / maximize and button are placed. 

Application Window  
 The window within which Excel 2007 runs. 

Quick Access Toolbar 
 The button on the quick access toolbar represent a command or a procedure. 
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Workbook Window 
 A window within the Excel 2007 application window in which a worksheet, chart, or dialog box is 

shown. 

MS-Office Button  
 This button is located in the upper-left corner of the Excel 2007 window. It open the menu 

containing commands like New, Open, Save, Save As, Share, Print, etc. 

Active Workbook 
 The Excel 2007 workbook window that accepts entries and commands. 

Inactive Workbook  
 A window that contains  Excel 2007 information. It is not affected by commands. Such a window 

has a gray title bar and is behind the active workbook window. 

Ribbon  
 Ribbon is displayed just below the title bar. In Ribbon, Commands are organized in logical groups, 

which are collected together under tabs. You can hide the Ribbon by double-clicking the active 
tab. Different type of Tabs of  Tabs are available in the Ribbon of Excel 2007. 

Home Tab 
 It contains the button related to the worksheet contents. 

Insert Tab 
 It contains the button related to the item which you can Insert in your worksheet.  

Page Layout Tab  
 It include the button related to the appearance of the worksheet. 

Formula Tab  
 It contains the button related to function.  

Data Tab  
 It contains the button related to data.  

Review Tab   
 It contains the button related to security and accurate data. 

View Tab  
 It contains the button related to view of the worksheet i.e. how you want to view the worksheet. 

Scroll Bar  
 The scroll bar appears at the left for vertical scrolling and at the bottom right for horizontal scroll 

bar. It split the sheet horizontally. 

Split Bar 
 The split bar is located at the top of the vertical scroll bar and to the right of the horizontal scroll 

bar. Double click the split button on the  

Sheet Tabs 
 A tab is near to the button of a workbook that display the name of a sheet. Click the sheet tab to 

move to the next sheet. To display the shortcut menu, right click the sheet tab. To scroll through 
the sheet tabs, use the tab scrolling button. 0 

Name Box 
 The name box is at the left end of the formula bar. It identifies the selected cell, chart item or 

drawing object. 

Formula Bar  
 The formula bar display the left constant value or formula used in the active cell. The formula bar 

is also used for editing the cell contents. 
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Shortcut Menus 
 Shortcut menus are meant to display frequently used commands relating to the selected item or 

object. 

Screen Tips  
 Screen tips show the name of the  command button shown in ribbon. Screen tips appear as soon 

as you position the mouse pointer on the toolbar button. 

Status Bar  
 Status bar appears at the bottom of the Excel 2007 window. It displays information regarding a 

selected command or an operation in progress   
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Chapter- 16  

INTRODUCTION 
Excel 2007 provides various methods of moving data and selecting specific data in workbooks and worksheets. 

Excel 2007 has various method of moving data and selecting specific data in workbook and worksheet. 

MOVING BETWEEN WORKBOOKS 

2.1  SWITCHING BETWEEN WORKBOOK’S WINDOW 

To switch between the open workbook windows, do this 
Click on VIEW tab in the window group → click on ARROW NEXT Switch window → Select your workbook  
Note: it will work when two or more workbook is opened 

2.2  CHANGING DEFAULT NUMBER OF SHEETS IN NEW WORKBOOKS 
1. Click MS OFFICE Button →Click EXCEL OPTION  
2. Click on POPULAR tab from Excel option dialog box 
3. Enter Number of Worksheet [5]  in include this many sheets spinner box  
4. Click on OK Button 

2.3  INSERTING AND DELETING SHEETS 
If you revise your workbook, you will want to insert / delete sheet from the workbook 

How will you insert a sheet in a work book? 

Method 1st : 
1. Right Click on SHEET tab → click on INSERT → WORKBOOK → click on OK 

                                               Or 
2. Click on NEW SHEET Icon (Near by Sheet Tab) 

Method 2nd : 
1. Click on SHEET Tab  → Click on HOME Tab → Click on INSERT(V) → INSERT SHEET 

Method 3rd  
1. To Insert worksheet press → Shift+F11 key 

 

How will you delete a sheet from a work book? 

Method 1st : 
3. Right Click on SHEET tab → click on DELETE  

Method 2nd : 
2. Click on SHEET Tab  → Click on HOME Tab →click on  DELETE → DELETE SHEET 

 

2.4  COPYING AND MOVING WORKSHEETS WITHIN A WORKBOOK 
1. Select Sheet you want to Copy or Move 

2. TO Copy -:  Drag Sheet with Ctrl Key and release to New Location 

3. To Move -: Drag Sheet and release to New location 

2.5  COPYING AND MOVING WORKSHEETS BETWEEN A WORKBOOK 
1. Open Both work  (Source and Destination) 

2. Click on VIEW Tab → click on Arrange All  → click on  Tiled (option ) → Click on Ok 
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3. Select Sheet you want to Copy or Move 

4. TO Copy -:  Drag Sheet with Ctrl Key and release to New Location 

5. To Move -: Drag Sheet and release to New location 

2.6  RENAMING A SHEET 
Method 1st : 

1. Right Click on SHEET tab → click on RENAME→ TYPE NAME(BRANCH)  
Method 2nd : 

2. Click on SHEET Tab  → Click on HOME Tab → Click on FORMAT(V) → RENAME SHEET → TYPE NAME 
OF SHEET 

2.7  GROUPING SHEETS FOR EDITING, FORMATTING AND REORGANIZING  
You can perform operation on several sheets at a time by creating a group selection. This group selection is 

useful to edit or format a group of sheets identically or to reorganize a group of sheet. 

TO SELECT A GROUP OF ADJACENT SHEET, DO THIS  

1. Select the First Sheet Tab  

2. Press and hold down SHIFT key → click on  the last sheet  

TO SELECT A GROUP OF NON ADJACENT SHEET, DO THIS  

1. Select the First Sheet Tab  

2. Press and hold down CTRL key → click on  the last sheet  

Note: when you select a group sheet, the word | Group| is displayed on the title bar. 

2.8  CONTROLLING THE DISPLAY OF SHEET TABS 
Click on Ms-Office Button → Excel Option → Advance → Click on the Show Sheet Tab check box → Click on Ok 

Button 

SCROLLING WITH MOUSE: 
To scrolling the window with the mouse, use the scroll bars located at the right and bottom of each worksheet.  

SCROLLING WITH KEYBOARD 

Key Movement 

↑ Scroll up one Row 

↓ Scroll down one Row 

← Scroll Left one Column 

→ Scroll Right one Column 

PgUp Scroll up one Screen 

PgDn Scroll Down One Screen 

Alt+PgUp Scroll Right One Window 

Alt+PgDn Scroll Left one Window 

Home Moves to the beginning of the row 

Ctrl+Home Moves to the beginning of the worksheet 

SELECTING CELLS AND RANGE OF CELLS  
Before you can enter, edit or modify the contents of a cell, you must select or activate the cell you want to 

change. 

 To select a cell-using mouse, do this 
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 Move the mouse pointer over the cell and click the cell 

 To select a cell using keyboard, do this 

↑ Moves the active cell up one cell 

↓ Moves the active cell Down one cell 

→ Moves the active cell Right one cell 

← Moves the active cell Left one cell 

Tab Enter  Data and moves the active cell right 

Shift+Tab Enter  Data and moves the active cell Left 

Enter Enter  Data and moves the active cell down 

Shift+Enter Enter  Data and moves the active cell Up 

Ctrl+ Arrow Move the active cell in the direction 
indicated by arrow until the edge of a block 
of data is reached 

Home Move the active to column A of the current 
Row 

Ctrl+Home Move the active cell to the first cell in the 
worksheet (cell A1) 

Ctrl+ End Move the active cell to the last cell in the 
used portion of the worksheet 

PgUp Move the active cell up one full window 

PgDn Move the active cell down one full window 

Alt+PgUp Moves the active cell one screen left 

Alt+PgDn Moves the active cell one screen Right 

USING GO TO COMMAND (F5 KEY) 
The Go To …. Command moves you to any cell or address in the sheet you request. If you choose a named cell or 

range of cells, with Go To , the entire range is selected. 

If you want to see the active cell, but it is not visible in the window, press Ctrl+Backspace  key together. 

How do you select a large range of cells using: 

a) Go To Command? 

b) Mouse? 

c) Extend Mode? 

Solution Part (A) 

1. Select one corner of range. 

2. Click on Home Tab  → Click on Find and Select from Editing Group → click on Go To or (Press F5 ) 

Key or Press (Ctrl+G) 

3. Type : the cell reference of the opposite corner in the reference : text box 

4. Press Enter 

Solution Part (B) 

1. Select one corner of range, Scroll the window so that the opposite corner appear. 

Or 
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2. Press and Hold down SHIFT key as you click the opposite corner. All cells between the 

two corners are selected 

Solution Part (C) 

5. Select a corner of the range by using the mouse or Keyboard 

6. Press F8 key to enter Extend Mode.  

7. Select the opposite corner → click it or move the key up to desire cell 

8. Press F8 again to turn Off Extend Mode 

2.9  SELECTING MORE THAN ONE RANGE OF CELLS 
Excel 2007 has the capability to select multiple nonadjacent ranges at a time. This feature helps you to format multiple 

ranges with a single command. You may even print different parts of the worksheet with a single print command. Similarly, 

you can erase multiple data entry cells with one keystroke.  

How do you select multiple ranges of cells with the mouse, do this 

1. Select the first range of cell 

2. Press the hold down Ctrl key as you select each additional range of cell 

3. Release Ctrl key 

3 . AUTO CALCULATE  
When you select a range of cells, Excel 2007 displays the sum of the selected ranges in the status bar. You can use this 

feature to find total or sum without creating a formula or using a calculator. Simply select the range of cells containing 

numbers you want to total. 

How can you change the Auto Calculate function? 

1.  Right click the status bar 

2. From the Pop-up List that appear 

3. Select the function you want to use for Auto Calculate, select  the range you want see in the status bar. 

4 SELECTING ROWS AND COLUMN WITH MOUSE  
To select an entire row / column with a mouse, do this 

1. Click on Row or Column heading. 

2. To Adjacent Rows or Column → Hold Shift key and press the last Row/ Column Heading 

3. To Non Adjacent Rows or Column → Hold Ctrl Key and press the Last Row / Column Heading 

5.. Selecting Cells By Type Of Contents 
Excel 2007 has a very useful command that enables you to select cells by contents or the relationship to formulas. This 

command is useful if you need to select the following 

  Cells containing values within an area of formulas 

 Related formula 

 Comments 

 A rectangular region that surrounds all touching filled cells  

 Array formulas 

  Erros 

 Embedded, graphical or charting objects 

To select cells according to their contents, do this 

1. Click on Home Tab  → Click on Find and Select from Editing Group → click on Go To or (Press F5 ) Key or Press 

(Ctrl+G) 

2. Click on Special Button ( Go To Special ) Dialog Box appear on screen 

3. Select option as given table 

4. Click on ok 
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Chapter -17 

Introduction 
The power of Excel 2007 lies in storing, manipulating, and displaying data items. Before you can 

manipulate and display data, you must enter it correctly. this chapter discusses the types of data you 

can enter in a cell of the Excel worksheet.  

Types of Data Entered in a Cell 

Text  

 Text in a cell can include any combination of letters, numbers and keyboard symbols. 

  A  cell can contain up to 32,0000 character 

  if column width prevents a text string from fitting visually in a cell , the display extends over 

neighboring cells.   

Numerals  

 A number may be displayed using commas, scientific notation, or one of many built in numeric 

formats 

 Date and Time are numbers but with special formatting . If you try to enter 1-9 as text string  

 When an unformatted number does not fit in a cell, it is shown in the scientific notation 

 When a formatted number does not fit within a cell, number signs like hash (###) are shown.  

Logical Value  

 You can enter the logical values such as TRUE or False into cells. Logical values are used in writing 

conditional formula 

 If you say  3>4, the result is False because 3 is not greater than 4  

Error  

 An error value is distinct type of data . For Example if a formula attempts to divide a number by 

Zero, the result is the #Div/0! Error value.  

Entering Data Items in worksheet 
 When you see the message Ready in the status bar then you can enter data items in a worksheet. 

Entering data in Excel 2007 worksheet actually consists of 3 steps 

 Activate the cell in which you want to enter data. 

 Type the you want to enter 

 Finalize the data entry by pressing Enter key, Tab, or any one of the arrow keys. 

 

 

 

 

 

 

Using shortcut keys for Data Entry  

DIFFERENT TYPES OF DATA ENTERED IN A CELL

TEXT : RAHUL SCIENTIFIC FORM : .

3.44E+14

NUMERALS: 100

FORMATED NUMBER: #########

DATE: 11/4/2014

LOGICAL VALUE FALSE TRUE ERROR #DIV/0!
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• To enter current date select the cell and press   Ctrl+; 

• To enter current time select cell and press   Ctrl+: 

• TO format a date in the default date format, press  Ctrl+# 

• To format a time in the default time format, press  Ctrl+@  

• Copies the formula from the cell above-    Ctrl+’ 

• Copies the value from the cell above –   Ctrl+”  

Moving the active Cell when Entering 

To quicken the data-entry process, select the range in which you want to enter data. The active cell 

would move automatically after pressing a data-entry key i.e. Entry button in  the formula bar.  

Data Entering Facilities auto fill feature  

 You can enter series in two ways: 

o  using mouse to drag the fill handle 

o Using a command that gives you the capability to create  many types of series  

Problem No1.            Using Mouse To Drag The Fill Handle  

1. Enter the first two element of data in the series 

2. Select these two cells and then drag the fill handle down or right to fill increasing and drag the 

fill handle up or left to fill in decreasing order 

3. The fill handle is the small square located at the lower right corner of selection 

4. Release the mouse button  

Problem No2.         Create a number series with the help of fill series dialog box.  

1. In the first cell, enter the first number 

2. Select the range of cells you want to filled 

3. Click on the Home Tab → Editing Group → Fill → series…. 

4. Click on ok button  

Problem No3           Creating Series of text and Heading  

1. Click MS OFFICE button → click EXCEL OPTION → click on Popular button →click on Edit 

Custom Lists.. 

Custom List dialog box appears as seen: 

2. Select new List in the custom lists: Box 

3. Click on ADD button 

4. Click on OK button  

AutoCorrect  

Autocorrect feature that recognizes common typing error and automatically correct them as you type, 

It can also be used as a short hand tool where you enter the abbreviations for long word so that on 

entering the abbreviation, it is replaced with actual word  

Problem No4      How will you add AutoCorrect Manually?  

1. Click on MS OFFICE Button → click EXCEL OPTION → click on PROOFING → click on Auto 

Correct Option. 

AutoCorrect option dialog box appear as seen 

2. In the replace : text box, type the error or abbreviation as you type 
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3. In The With : text box type the correct spelling or abbreviation short term of the word 

4. Click Add to add the new entry to the list of autocorrect entries  

5. Click on OK Button  

Validation of Data  

Data validity is a check to determine whether data entered into a cell, defined by a set of criteria 

that you may set.  

Problem No5.             To specify the data validation settings, do this:  

1. Select a cell or range for which you want to validate cell 

2. Click on the Data Tab→ Data Validation → 

 Click on setting Tab property sheet: 

1. Select type of data to be validate or checked from the ALLOW drop down list 

2. Select an operator for validation from the Data 

3. Enter the appropriate values in Minimum and Maximum  

 To specify an input message, do this  

1. Click the Input Message tab in Data Validation dialog box 

2. Click the Show input message when cell is selected so that the check box is ticked 

3. In the Title Box,  enter a title for the message 

4. Type the text of the message in the Input Message box. 

5. Click on ok to save setting  

 To specify an error alert, do this  

1. Click Error Alert tab in the Data Validation dialog box 

2. Click the show error alert After invalid data is entered  

3. Select style  for the message from the drop down list 

4. Enter Title for the message in the Title : Box 

5. Enter the text for the Error Message  in the Error  Message Box 

6. Click on Ok Button  

Auto Complete  

Auto complete to make it easy for data entry operator to enter repeated text items in a column. Thus 

you only need to type repeated text once only. The next time you want to type the same  text in or at 

the bottom of the column , you can type the first few letters of this entry. Excel will complete the rest 

of the entry. You need to press enter key to make the entry .  

Editing cell entry  

1. To edit an entry directly in a cell  or press F2 

2. Double click the selected cell 

Problem No6.           Moving Data and Formula  

1. Select the cell or range of cells you want to move 

2. Move mouse pointer over the selection border. The pointer changes to an arrow 

3. Drag the pointer and gray outline of selection to new location 

4. Release the mouse button when the gray outline is where you want to place the selected range.  

Problem No 7.           Copying DATA AND FORMULA  



DEVELOPMENT TECHNICAL INSTITUTE – 
 

THIS FILE IS CREATED BY MR KAPIL KHANDELWAL DIR (DTI) Page 67 
 

1. Select the range of cell you want to copy 

2. Hold down Ctrl+ key and move pointer over an edge of the selection. 

3. Drag the edge of the selection to where you want to copy.  

Problem No8           Dragging and inserting cells to move and insert data, do this: 

1. Select the cell or range of cells you want to move 

2. Move the mouse pointer over the selection’s border . The pointer changes to an arrow 

3. Press and hold down the SHIFT key and drag the pointer to where you want the data inserted 

.the location where the data is inserted appears as a grayed partial cell boundary  

Problem No9        Inserting cells with copy command  

Select cell or range of cells you want to copy 

Click on the Home Tab → click on Copy →Right click on the  cell →  insert Copied cells 

 Select from the following option 

o Shift cells right   

o Shift cells down 

 Click OK 

Problem No 10         Moving information across a workbook  

1. Select cell or range of cells 

2. Click home tab → Cut(Ctrl + X)  

3. Click Paste (Ctrl + V)  

Note:  

You can also drag a selected range to another worksheet in the workbook.  

To do so hold down the ALT key then drag the selection sheet tab.  

1. Filling or Copying cell contents with Fill handle  

2. Using the fill handle 

3. Using Ctrl+ Enter Keys to fill cells 

4. Fill cells using command button 

5. Using across worksheet 

Problem No 11               Replacing Text, Number or Formula 

The Replace command enables you to locate an entry and then replace the same in one step. 

To Find and Replace do this: 

1. Click the Home tab and the Editing group → Click the Find and Replace and choose the Replace 

(CTRL +H) 

2. In the Find what: 

3. In the Replace with: 

4. Click Replace All button to find and replace all matches 

5. Click the Find next to find match. Replace to replace the current found item. Click close button 

to stop the search. 
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Chapter - 18 

Introduction 

Excel 2007 has several methods for formatting data as well as the complete worksheet so as to 

make reports, tables and charts easier to read and understand. Excel 2007 enables you to: 

Contents:- 

 Change column width 

 Change the height of rows 

 Change numeric and data formats 

 Change the font size, color, and style of character  

8.1 FORMATTING ROWS AND COLUMN  

In order to improve the appearance of a worksheet or table in it, you can adjust column width and 

rows height, thus you can fit more data on a page, if need be , you can even hide confidential data  

       Adjusting columns width 

You can adjust the width of one or more columns to get a better look in a worksheet. If a column is 

not wide enough to display a number, date or time Excel 2007 displays it using # character in the 

cell. Therefore, you may need to adjust column width to show complete information. 

Problem No1. How To Adjust Column Width With Mouse  

1. Select the column  

2. Move the pointer onto the column separator to right of column heading 

3. Drag the column Left or Right until the column is of the required width 

4. Release the mouse button  

Problem No2. How To Adjust Column Width Using Command Button  

1. Select the column  

2. Click Home tab → click Format under the cell group 

3. Select any one option to adjust column width 

a. Column Width → Define Size → Ok 

b. Auto fit selection 

c. Default width  

Problem No3. How To Copy A Column Width  

1. Firstly Make Any Format With Different Size Of Column 

2. Select Cells In The Column  

3. Click Home Tab → Click Copy Button From Clipboard Group 

4. Click  Home Tab → Click Paste Special Button From Clipboard Group 

5. Click On Column Width → Click On Ok 

Problem No4. How To Hide Column 

1. Select the column you want to hide 

2. Move the mouse pointer over the column separator line 

3. Right click on column → click on Hide  
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Method 2nd  

Click on HOME tab → FORMAT under cell group → click on HIDE & UNHIDE from visibility → 

click on HIDE column  

Problem No5. How To Unhide Column 

1. Select Both COLUMN  

2. Right click on COLUMN → Unhide Column  

Method 2nd  

 Click on HOME tab → click Format from cell gr oup → click UNHIDE column  

How would you adjust row height 

 Using mouse 

 Command Button 

Problem No6. How To Adjust Row Height With Mouse  

 Select the Row 

 Move the pointer onto the row separator to below of row heading 

 Drag the Row Up or Down until the Row is of the required Height 

 Release the mouse button  

Problem No7. How To Adjust Row Height Using Command Button  

1. Select the Row 

2. Click Home tab → click Format under the cell group 

3. Select any one option to adjust Row Height 

a. Row Height→ Define Size → ok 

b. Auto fit selection 

c. Default width  

8.2  Formatting cell and their entries 

You can use different character fonts and styles in an Excel 2007 worksheet. You can also change font 

colors, which appear on screen. If you have a color printer, you print worksheet with these colors.  

Formatting all characters in a cell or Range of cells 

 Click the Home tab → Click the cells group → click arrow next to Format. Here select Cells......... 

 Click on the Home Tab → Click the Font group → Click the Dialog Box Launcher a small icon 

 Select the Font from the Font: list 

 Select the font style from the Font style: list 

 Select the font size from the Size: list. 

 Select underline style from Underline drop-down list. The underline options are None, Single, 

Double, Single Accounting and Double Accounting. 

 Select a color from the Color drop-down list. 

 Click the preview box shows the result of the chosen formatting options. 

 click the OK. 
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Formatting only the selected Characters in a cell 
You can change the appearance of part of the text within a cell just as you change the appearance of a 

cell or range of cells. Formatting selected characters in a cell is useful for emphasis on specific words, 

titles, etc. 

To format characters within a cell using Ribbon command do this: 
 Follow steps 1 and 2 as above 

 Select the Font from the Font list box. 

 Select the font size from the Font size: Drop down list box. 

 Click the Bold Button to make the character bold 

 Click the Italic button to make the character italic 

 Click the Underline button to make the character underlined. 

 

8.3  Aligning and Rotating Entries in the cell 
 In an unformatted cell, you would have noted that text aligns against the left edge of the column 

and numbers align against the right edge. However, you can align values or formula results so that 

they are left, right or center aligned in a cell,. Aligning a title across a selection f cells enables you to 

center a heading over a table or report. 

 

8.4  Centering text across cells 

1. MERGE AND CENTER BUTTON 

The Merge and Center button does two things in one step. First, it merges the selected cells and 

then it centers the text in the left-most cell within the merges cell. The Merge cells option enables 

you to select a range of cells and include them into just one cell 

Problem No. 8 How TO Merge Cell? 

1. Select Two or More cell 

2. Click on Merge and Center Button from Home Tab 

3. Type Text in The cell  

 

2. WRAPPING TEXT SO AS TO FIT WITHIN A CELL 

Excel 2007 gives the option to wrap the text and to adjust it like a paragraph fitting within a cell. 

The cell's height increases to accommodate many such lines. 

Problem No. 9 How TO Wrap Text Cell? 

1. Select cell 

2. Click on Wrap Button from Home Tab 

3. Type Text in The cell  

 

Enter a line break within text in a cell do this: 

1. Start typing in the formula bar in the cell. 

2. When you need to break a line, press Alt + Enter keys. The Wrap text option is automatically 

applied to the cell. 
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Shrinking Text so as to fit within a Cell 

 When the cell entry is larger than the size of the cell then you can use the shrink option to fit within 

the cell. In this option, the contents are reduced in size so as to fit within the cell. 

Problem No. 10  How to Shrinking Text so as to fit within a Cell 

1. Type Text in Cell 

2. Press Ctrl +1 key 

3. click on Shrink Box 

8.5 Rotating Numbers and Text 

Text is seen horizontal and read from left to right. But excel 2007 given you the option to align text so 

that the letters can be stacked. It means, you can read text from top to bottom. 

Problem No. 11 How To Rotate Number and Text in Cell ? 

Solution: 

1. Type text / Number in Cell 

2. click on Home tab → Click on Orientation button → select any one 

8.6  Adding color Pattern and Border 

Shading, border and colors in a worksheet would enable you to make worksheet or reports appear 

attractive. You can make important information stand out. Such features create an impression on your 

readers to be of high-quality work. 

Problem No. 12 How To Adding a Pattern on color 

1. Select the cell to which you want to add color/pattern. 

2. Click on  HOME tab → click On FORMAT → Format Cell→ Fill tab property sheet  

3. Select The Background Color From Background Color Group. 

4. Click on Fill effects…… Button to apply different shading style and set the transparency. 

5. Select a pattern color from the Pattern color: drop-down list. 

6. Select a pattern style from the Pattern Style: drop-down list 

7. Click OK. 

8.7 Adding Borders and Lines to cells in a Worksheet 

You can place border around cell or lines and double lines. This is to add emphasis as well as to define 

data-entry areas. This also helps to mark total and subtotal, to appear distinct. 

Copying formats from cells to other cells 

 Excel 2007 gives a way to use format which you created for a cell or range of cells. With the Format 

Painter button, you can copy the formats from one cell and copy it to another cell. 

Problem No13. How To Apply Border Format in Cell? 

1. Select Cell 

2. Click on Home Tab → Format →Format Cell  

3. Click on  Border Tab 

4. Select Border Style and Border Color 

8.8 Format Painter Button 
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The format painter button is designed to let you copy the formatting information from selected 

cell or range of cells. You can then apply that format to another cell or group of cells. Notes that all 

format information attached to the selected cells would be copied. 

8.9 Protecting workbook 

With Excel 2007, you can protect cells, graphical objects sheets windows, and even an entire 

workbook. To prevent unauthorized people from changing the protection status or the display of 

hidden information, you can also use the facility for password. 

 The Procedure For Protecting A Worksheet And Its Contents Involves Two Commands: 

o The first command formats the cells or objects that you want protected. 

o The second command turns on protection for a sheet or the entire workbook. 

Problem No. 14 How To Protect Sheet? 

1. Click on Review Tab 

2. Click On Protect sheet 

3. Type Password 

4. Click On Ok button 

Problem No. 15 unprotects the sheet, do this: 

 Under Review tab → Click the Unprotect sheet from Changes group 

 In this dialog box, type the password, if you give any to unprotect the sheet and then click OK. 

Problem No. 16 changing the standard font 

 Click the Office Button → Click the Excel Option → Click the Popular button in left side 

 When creating new workbooks 

 Click the OK 

 An alert box appears, warning that you must restart Excel 2007 before the new standard font can 

take effect. Click Ok 

Conditional Formatting 

Conditional formatting is the process of formatting cells automatically based on the data they 

contain. When the data changes and triggers a predetermined condition, Excel 2007 automatically 

changes the cell's format. 

Problem No. 17 Format cells using data bars 

1. Select range of cells in which you want to apply formatting with data bars. 

2. Under Home tab →Click the Conditional Formatting from the style group. 

3. Click the Data bar. 

4. Set the condition and click the OK button. 
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Chapter -19  

Introduction  
 A name assigned in excel 2007 worksheet is considered as a recognizable and memorable label for 

a single cell or range of cells. For ex, the name sales 2007 is easier to recognize and remembered 

than the cell reference such as B4:G18.  

Importance of names in worksheets  
 By giving name to cells, we can add clarity, ensure reference integrity, and increase productivity. 

Moreover: 

 Name makes formula easier to understand and maintain. 

For example:- 

Profit = sales – cost  

Makes it easier to understand than=C3-B3, especially if we need to revise the worksheet after a long 

time. 

II. Name help us in speeding up worksheet navigation. It also simplifies entering formulas. 

III. Name make formula easy to remember and maintain. We can redefine a named reference, and 

all formula that use that reference are updated automatically. 

IV. When we have named range of cell,  then adjustment would we automatically done up, when 

some rows or cells are added or deleted.  

Rule to define names  
 There are several rules we must adhere to, while defining names for the cell or range of cells. There 

are as follows: 

 A name can only contain the characters namely, A-Z (upper or lowercase allowed), number (0-

9), period (.), and under score (_). 

 The first character must be an alphabet or underscore. 

 Names cannot be longer than 255 characters. 

 Spaces are not allowed, underscore and period may be used as a word separator. 

 A name cannot be the same as a cell reference, such as B3 or Y2007.  

 Name are case-retentive, but not case-sensitive. For example, when you define the name 

SALES, then define the name Sales again then the second name will replace the first reference.  

Applying names to workbook / worksheet.  
 Names can be given at workbook level (i.e. global names). They can also be applied at the 

worksheet level (i.e. level names). To define names at workbook /worksheet level, click under 

Formula Tab and then in the named Cells group click arrow next to Name a Range and then select 

name a range.  

Naming Cell  
 Excel 2007 offers the following methods to give name to cells. 

o Using the new Name dialog box. 

o Using the Name manager. 

o Using Name Box 
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o Creating form Selection  

Naming Globally using new name Dialog Box.  
Names that define globally apply to all the sheets in that workbook. for example, if a cell on sheet1 is names 

average and you are working in sheet2 and if you open the name box and select average in the list sheet1 

becomes the active sheet and the cell names average is selected. 

Example1 How do you define a name globally using new name dialog box? 

 Solution  

A. Select range of cell (s) you want to name. 

B. In the new name dialog box, type the name of range in the name: box. 

C. Choose the scope of the ranged name i.e. workbook in the scope: box for global naming. 

D. If you want to give comments, you can give in the comment box. 

E. Refers to: collapsible box display the current selection. To current selection, you can enter a new cell 

reference and then click OK button. 

   To use the same name to define cells or ranges on more than one sheet in a workbook, you need to 

create sheet-level names.  

Local Naming using New Name Dialog Box. 
 The area of local is limited only to the sheet. This names cannot display on the name box on the left of the 

formula box that shows the name of the cell or cells. 

Example 2:- How do you define a name locally using New Name dialog box? 

 Solution 

A. Select range of cell (s) you want to name. 

B. In the new name dialog box, type the name of range of cells in the Name: box. 

C. Choose the scope of the ranged name i.e. sheet (n) in the Scope: box for local naming ,where n is the 

number of the sheet. 

D. If you want to give comments, you can give using the comment: box. 

Refers to:- collapsible box display the current selection, you can enter a new cell enter a new cell reference 

and then click OK button. 

Local/global naming by using Name manager dialog box 
 To define a name globally/locally by using name manager, do this: 

1. Select range of cell(s) you want to name. 

2. Under formula tab and then in the named cells group click name manager. Name manager 

dialog box appears as seen in fig . 

3. In the dialog box, click on new…button to display the new name dialog box to create new name 

to range. 

4. Click on the edit… button to display the dialog box for editing the range or the name of range. 

5. Click on the delete button to delete the range. A confirmation dialog box appear asking 

whether you want to delete the range name or not.  

6. Click the arrow next to the left filter button and choose the option. If you want to see the list of 

named range using filters, select list according to the requirement.  

Using the Name Box  
 The name box appears at the left end of the formula bar. The reference area displays the cell 

reference for the active cell or the name of the currently selected cell or cells, if they are named. 



DEVELOPMENT TECHNICAL INSTITUTE – 
 

THIS FILE IS CREATED BY MR KAPIL KHANDELWAL DIR (DTI) Page 75 
 

   If you enter a name that is already used the cell or range of cells with that name is selected, 

rather than the current selection being given that name.  

Naming Non adjacent cells  
 Excel 2007 enables you to name non adjacent of cells using the new name dialog box or the name 

box. However, you cannot use the create names from selection dialog box for cells that are non 

adjacent. 

  To select non adjacent cell or ranges make the first selection then press and hold down CTRL key 

and make other selection  

Changing and deleting names  
 If you want changes a name or the cells that the name refers to or you want to delete the names 

you no longer need, then use the method.  

Working with names in formulas and commands  
 You can use names in place of cell or ranges of cells reference. In formulas you just type a name. 

you can use names even in dialog boxes to indicate a cell reference or range of cells. Just type the 

name in the edit box requiring the reference. 

   If you use name in formula that Excel 2007 cannot find the #Name? Error is shown.  

Working with formulas  
 A formula is entered into a cell. It performs a calculation of some type and returns  result, which is 

displayed in the cell. Formulas in Excel always begin with an equal sign (=).  

Entering cell references  
 Cell references allow you to use values from different parts of worksheet and execute and enables 

you to do the desired calculation. You can use any cell or group of cells in a formula. The reference 

of the active cell is displayed in the name box at the left end of the formula bar.  

 Type of cell reference 

o Using Relative Reference:-A relative cell reference in a formula is based on the relative position 

of the cell that contains the formula and the cell the reference refers to. If the position of the 

cell that contains the formula changes, the reference is changed. If you copy or fill the formula 

across rows or down columns, the reference automatically adjusts. 

o Using Absolute References: -You use absolute references only to keep the cell reference values 

from changing as and when you copy a formula to a new location in a worksheets. 

Indicate absolute reference putting a dollar sign ($) in front of the column letter or row number 

that you want to frees or both. 

o Using Mixed References:-You can create mixed references the same way as you can create 

absolute references. Type the dollar signs or specific row and column numbers without 

brackets or press F4 key. Each press of F4 cycles the cell reference to a new combination. 

Each time you press F4 key Excel cycles through all combinations of relative and absolute 

references. Press F4 key four times, for example and you cycle from B22 through $B$22,$B22, 

and B22 

Using Operators in Formulas 
 Operators are used in formulas to execute operations on the values taken by formulas. Excel 

uses for type of operations. These given below 
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o Arithmetic Operator: -How to use each of the arithmetic operators in formulas is 

explained in the following :-  +,- ,*, %, ^ 

o Text concatenation operator:- The ampersand (&) operator joins text within quotation 

marks or text contained in referenced cells. Joining text is known as concatenation 

operator: 

o Comparative Operators:- To compare values you can create formulas using comparative 

operators. These operators return a TRUE or FALSE result, depending o how the formula 

evaluate the condition. Subsequent table formulates some Comparative operates and the 

figure below 

 

=   Equal to 

<   Less Than 

<=   Less than or equal to 

>   Greater Than 

>=   Greater than or equal to 

<>   Not equal to 

o Reference operator:-Reference operators make no changes to constants or cell contents. 

Instead they control how a formula groups the cells and ranges of cells when the formula is 

made to calculate.  

o Range Operator:- Use the range operator(:) to reduce your work in formulas. If you want a 

formula to refer to all cells in column B, type B:B similarly the range that includes all cells in 

rows 5 through 12 is entered as 5:12. 

Changing formula to values 
 When you want to freeze a formula's result so that a formula changes to a value, then do as 

follows: 

 Select the cell of an existing formula and press F2 or click the formula bar, or double-click the cell if 

you are using in cell editing. 

 Press F9 key. 

 Click the OK or Press Enter key. 
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Chapter -20  

Entering function in a worksheet 

You can operate a function using any of the following two ways. 

 You can type the function name and the required arguments in the formula bar. To use this method 

you need to remember the name of the function and the arguments to be passed.  

 Insert the function-- this is an easier method because excel 2007 inserts the function and asks you 

to fill in the parameters only. 

Using the insert function 

 Use the insert function to make your job much easier. The insert function guides you through the 

process and explains each function as well as each argument within a function. 

Edit function manually do this: 

 Select the cell contains a function 

 Press F2 key to activate the formula bar or click in the Formula bar. 

 Select the argument in the formula you want to change. 

 Enter the new argument by typing, dragging, pasting a name, or inserting a function 

 Press Enter key. 

Math and Trigonometry Functions 

 Excel 2007 includes many math and trigonometry functions. Mathematical function are used to 

perform wide verity of simple or complex calculation such as totaling the value for a range of cells, 

rounding of a number . 

 Sum    it adds all the Number in a range of cells. 

 Syntax = sum (Num1, Num2, Num3…….)  

 Round Round a number to a specified number of digits.  

 Syntax: = Round (Number, Num_Degit) 

 Round Up Round the number up, towards zero. 

 Syntax: = Roundup (Number, Num_Degit) 

 Round Down  Round the number down, towards zero. 

 Syntax: = Round Down (Number, Num_Degit) 

 ABS   it returns the absolute value of a number, a number without its sign.  

 Syntax → =abs (Number 

SQRT  it return the square root (Positive square root) of a number 

 Syntax →SQRT (Number) 

 SUMIF   Adds the cells specified by a given condition or criteria.  

 Syntax: =SumIF (Range, Criteria, Sum_Range)  

Logical Functions 

 Logical functions are used when we want to check whether a given conditions is true 

or false 



DEVELOPMENT TECHNICAL INSTITUTE – 
 

THIS FILE IS CREATED BY MR KAPIL KHANDELWAL DIR (DTI) Page 78 
 

 IF   check whether condition is meeting, and returns one value if true, and another 

value if false. 

Syntax: = IF (Logical test, true, false) 

 TRUE  TRUE () returns the logical value TRUE and it takes no arguments. 

 Syntax TRUE() 

 FALSE   FALSE ()function is same as TRUE() but it returns the logical value FALSE. 

Syntax FALSE() 

 And    Checks whether all arguments are true, and return true if all arguments are true. 

Syntax: = And (Condition1, conditon2, conditon3...) 

 Or   Checks whether any of the arguments are true, and return true or false, returns false 

only if all arguments are false. 

Syntax: = Or (Condition1, condition2, condition3) 

 Not    Change false to true, true to false. 

Syntax: = Not (Logical) 

Statistical Function 

 Statistical functions are used to perform statistical analysis on ranges of data. It includes simples 

well as complex statistical functions such as average, min, max, standard deviation slopes. etc  

 Max   Returns the largest value in a set of value. 

Syntax → =max (Num1, Num2, Num3…….)  

 Min  Returns the smallest value in a set of value. 

Syntax → =min (Num1, Num2, Num3…….)   

 Average   Returns the average of its arguments.  

Syntax → =Average (Num1, Num2, Num3…….)  

 Count  Count the number of cell in a range that contains number. 

Syntax → =count (Num1, Num2, Num3…….)  

 Count A  Count the Text of cell in a range that contains number. 

Syntax → =CountA (Text 1, Text 2, Text3…….)  

 COUNT IF   count the number of cells within a range that meet the given condition in 

Criteria  

Syntax: =CountIF (Range, Criteria)  

Date and Time Function 

 With date and time functions, you can analyze and work calculate with date and time value in 

formulas. For example, if you need to use the current date in a formula, you can use the TODAY() 

function, which returns the current Date. 

 Today → Return the current date formatted as date 

Syntax → = today ( )  

 Now→ return the current date and time formatted 

Syntax → Type the formula =now ()  

 Month → Return the current month Jan to Dec. 

Syntax → Type the formula =month (serial_number)  
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 YEAR → Returns the year corresponding to date. 

Syntax → Type the formula =year (serial_number)  

Text and Data Function 

 With text function, you can use text strings in formulas. You can also change the case of the string, 

find out the length of a text string or you can join two strings etc. 

 Concatenate   joins several text strings into one text string. 

Syntax: =concatenate (Text1, Text2, text3,…..) 

 Upper   Convert a text string to all uppercase letters. 

Syntax: = Upper (text) 

 Lower    Convert all letters in a text string to lowercase 

Syntax: = Lower (text) 

 Proper   Covert a text string to proper case, the first letters in each word in uppercase and 

all other letters to lower case. 

Syntax: = Proper (text) 

 Len    Returns the number of character in text string. 

Syntax: = Len (text) 

 Left   Returns the number of character from the start of a text string. 

Syntax: = Left (text, Num_Degit) 

 Right   Returns the specified number of character from the end of a text string. 

Syntax: = Right (text, Num_Degit) 

 Mid   Returns the character from the middle of a text string, given a starting position and 

length.  

Syntax: = Mid (text, Num_Start, Num_Degit) 

Financial Function 

 Financial functions perform common business calculations. For example, determination of the 

payment for a loan. 

 SLN → Returns the straight-line depreciation of an assent for one period 

 Syntax: =SLN(cost, Last_value,Life) 

 PMT→ Calculate the payment for a loan based on constant payments and a constant interest 

rate. 

Syntax: = PMT (ROI/No_of_installment, No_of_installment*time period,-loan amount) 

 Fv  FV function allows you to calculate the Maturity amount using the FV formula 

Syntax  = FV (ROI/ No.Of_Installment, No_Of_Installment,-Installment Value, -Initial 

Deposit, Payment Type) 

 Goal Seek → Goal seek is used to set the target value by 

changing cell value. 

 Firstly select the cell of maturity amount 
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 Use goal seek method to find the desired value by using command (Alt+A+W+G) 

 TYPE THE DESIRED VALUE -7000 

 CLICK ON by changing cell and select the cell of “installment value”  

 Click on Ok button and see the target or current value  

finally click on Ok Button. 

  With Goal seek, you specify the value you want a formula 

to calculate and then Excel 2007 changes the data in the 

formulas cell reference to tell you what values you need to 

achieve that goal. 
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Computer Lab Work 

ASSIGNMENT 1ST: 

 

ASSIGNMENT NO2: 
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Introduction  

You can create different type of chart using excel 2007 that will help you to analyze data in a 

worksheet and give you a visual presentation of result. You can even customize the chart by adding 

text, arrows, title, and legends etc.   

Types of Charts?  

There are two types of charts namely, EMBEDDED chart and CHARTS that appear in a chart sheet.  

1. Embedded chart  

An embedded chart appears in a worksheet next to tables or text. Embedded charts are required 

when you want a chart side-by-side with the data for the chart, as in the case of a case of a report 

document. 

2. Chart in a chart sheet  

A chart can be created by itself in its own chart sheet within a workbook .you are able to work with 

the chart sheet separately from the worksheet contain data. If you insert a chart in a sheet, you 

add the chart to the active workbook and save it along with workbook. 

Quickly Generate Chart  

 To quickly create chart - 

 Select data and press F11 key → chart In chart sheet 

 Select data and press Alt+ F1 key → Embedded chart in same sheet  

Standard Chart Types  

 Excel 2007 can draw eleven types of charts. It gives you option for representing data most 

effectively using any of these types charts. Each of these chart types have several sub- types. Many 

chart type may also have 3d sub types  

1. Column Chart  

A column char compares separate items as they vary over time. Column chart are used for 

comparing different items by placing them side by side. Cylinder, cone and pyramid chart available 

in the same cluster.  

2. Bar chart  

A bar chart is similar to a column chart except that categories are on the vertical (y) axis and the 

value on the horizontal (X) axis.  

3. Line Chart  

The line chart compare trends over a period of time. Line chart is used in production, sales, or stock 

market situation to show trend of revenue or sales over a period of time  

4. Pie Chart  

A pie chart compares the sizes of pieces in a whole unit. This type of chart is used when the parts 

total 100 percent for a single series of data. Pie chart show the percentage of mix in product 

shipped , mix in income sources, or mix in target population. Wedges in a pie chart can be pulled 

out from the pie to emphasize the data point  they represent. To explode a slice of a pie Chart, click 
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a second time to select the individual slice. Drag the slice away from the pie. Release the mouse 

button when the slice is positioned where you want it.  

5. XY (Scatter) Chart  

A Scatter Chart or XY chart is useful for trends of collection of revenue in a company over uneven 

intervals plotted on the x-axis.  

6. Area chart  

 An area chart compares the continuous changes in volume of multiple data series. This type of 

chart sums the data from all the individual series to create the top line that enclose the area, giving 

the view of how different series contribute to total volume. Use this chart for sales and production 

figures of a company to show how volume changes over time and to emphasize the amount of 

volume to change.  

7. Doughnut Chart  

 Similar to pie charts, doughnut charts compare the sizes of pieces in a whole unit. The arrangement 

of the doughnut chart enables you to show more than one data series.  

8. Radar Chart  

 The radar charts are used to show the relationship between individual data series and between a 

specific series and the whole of the other.  

9. Surface Chart  

 The surface charts show high and low points along a surface. Surface charts are an excellent way to 

visually locate high and low points resulting from two changing variables. Surface charts can 

highlight relationship between data that would not otherwise be easy to ascertain. Colors and 

patterns are used to indicate areas of the same value in a surface chart.  

10. Bubble Chart  

 A bubble chart allows you to represent three variables on a two-dimensional surface. The first two 

variables are plotted against the category (X) and value (Y) axes, just as in an XY (Scatter) chart. The 

third variable is represented by the size of the bubble. To create a bubble chart, you need three 

rows or columns of values, one each for X and Y values and one for the bubble size.  

11. Stock Chart  

 Stock charts display stock prices over time. You can display high, low closing prices and volume of 

stocks traded.  

Creating a chart 

 Select the data items you want to appear as charts. 

 Click the Insert Tab → Click the chart from the Chart Illustration group. 

 Click the Next to that chart which you want to insert and then select the chat from the chart 

subtype. 

Changing the types of a chart 

 Excel 2007 offers you eleven different chart types and within each of these general types, you can 

select any sub-types. The easiest way to create charts is to select a chart type and sub-type you 

want. Thereafter, you may customize this chart according to your requirement. 

Changing Data Source 
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 You can add to an existing chart. You can even add new data series or data point to 

existing series or change the range of data used by a chart. 

Inserting  

 

Assignment: 
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Introduction 

 You can set merging and fonts and include headers/ footers as well as titles while printing a 

worksheet. You can even print multiple copies of entire or a part of it. Moreover, before you print, 

you can preview a worksheet to see how it will look when you print it.  

Setting up worksheets for printing  

 Before you actually print worksheet, it is better that you change the page setup as per the printer 

and paper you are going to use for printing a worksheet. 

 Page setup opting in excel involves four categories namely, page margins, header/footer and sheet.  

Margins option  

 To set the margins dot this: 

 Click the margins tab of the page setup dialog box, the proset the margins and select the position of 

headers, footers and print areas from the margins tab in the page setup dialog box. Option are 

available: 

left, Top, Right , Bottom, Header, 

Footer, Center on page Horizontal,  Vertically  

Headers and footers  

 You use headers for company names and report titles, etc. the footers are commonly used for page 

numbers and printout dates/times 

 If need be, you can use the built in header/ footer option in excel or you can specify custom 

headers/footers.  

To use a built in headers/footer do this:  

 In the page setup dialog box, click header/footer tab property sheet. 

 In the header: drop-down list select the built in header. 

 In the footer: Drop-down list select the built in footer. 

 Click OK.  

To specify print title, do this  

 Print titles are not the same as page headers. However they can be used for similar purposes. Also 

a page can set up both print titles or page headers or both.  

Deleting a print area or print titles  

 If you want to print the entire worksheet instead of predefined print area then you must first 

delete the print area in the print area edit box. 

To delete the print area do this: 

 Click the File menu highlight print area then click Clear Print area. Alternatively, in the sheet tab 

property sheet of Page sheet dialog box clear the print area edit box.  

 Previewing a worksheet before printing  

To print preview a worksheet, do this: 
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 Click the file menu and choose print preview. Alternatively, click the print Preview 

button on the standard toolbar. 

 Excel switches to print preview mode. 

 Print Preview should be carried out to confirm that you want to print the worksheet as you see it 

on the screen.  

How to set page breaks in worksheet?  

 When you print a worksheet excel automatically creates page breaks where needed. But it also 

gives you an option to insert page breaks manually too.  

Showing automatic page breaks, do this  

 Automatic page breaks are not shown on the worksheet, when the sheet is viewed in the Print 

Preview mode for the first time. 

To display automatic page breaks, do this: 

 Click the tools menu and choose option. The options dialog box appears. 

 Click tab view tab. The view tab property sheet appears as in. 

 Check the page breaks option. 

 Page breaks are shown by broken lines which run along the gridlines.  

Printing an excel worksheet  

 To print a worksheet works sheet do this: 

 Click the File menu and choose print. The print dialog box. The print dialog  box is similar to 

Microsoft word print dialog box. Alternatively click the print button on the standard toolbar. This 

prints the selects worksheet immediately and will not show a dialog box.  

Printing formulas  

 By default a worksheet is printed as displayed on the screen. But you can print the underlying 

formulas instead. 

To print formulas, do this: 

 Click the tools menu and choose options, then selecting the view tab. In the view tab property 

sheet appears. Check the formulas check box (or press Alt + R to display the formulas.  

 

  


